OpenStack Manila Unprivileged users can retrieve, use and manipulate share networksGHSA-jx7v-gmqc-6xrj
HIGHFix: openstack/manila@947315fGHSA-jx7v-gmqc-6xrj is a high-severity (CVSS 8.3) Incorrect Default Permissions vulnerability in manila. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for manila — see the affected versions and patch details below.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
manila🐍manila🐍manilaReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
OpenStack Manila <7.4.1, >=8.0.0 <8.1.1, and >=9.0.0 <9.1.1 allows attackers to view, update, delete, or share resources that do not belong to them, because of a context-free lookup of a UUID. Attackers may also create resources, such as shared file systems and groups of shares on such share networks.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | manila | all versions | 7.4.1pip install --upgrade 'manila==7.4.1' |
| 🐍PyPI | manila | ≥ 8.0.0&&< 8.1.1 | 8.1.1pip install --upgrade 'manila==8.1.1' |
| 🐍PyPI | manila | ≥ 9.0.0&&< 9.1.1 | 9.1.1pip install --upgrade 'manila==9.1.1' |
Affected Products
manilaopenstackResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for manila, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update manila to 7.4.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-jx7v-gmqc-6xrj is resolved across your whole dependency graph.
Workarounds
Close the privilege gap rather than the entry point: audit which accounts, roles and service identities can reach the affected operation, drop the component to the least privilege it actually needs, and review file and directory permissions created by earlier installs — a default left in place is what makes this reachable.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
There is no known mitigation for this issue, the flaw can only be resolved by applying updates.Source: Red Hat security advisory for GHSA-jx7v-gmqc-6xrj (CC BY 4.0)
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat OpenStack Platform 13.0 (Queens) | openstack-manila-1:6.3.2-3.el7ost | RHSA-2020:2729 |
| Red Hat OpenStack Platform 15.0 (Stein) | openstack-manila-1:8.1.1-0.20200311070441.17b29e2.el8ost | RHSA-2020:1326 |
| Red Hat OpenStack Platform 16.0 (Train) | openstack-manila-1:9.1.2-0.20200405045746.f071a43.el8ost | RHSA-2020:2165 |
Frequently Asked Questions
Is GHSA-jx7v-gmqc-6xrj in your dependencies?
Find it across PyPI, including transitive dependencies.