NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
CRITICAL severity

LaRecipe is vulnerable to Server-Side Template Injection attacksGHSA-jv7x-xhv2-p5v2

CRITICALFix: saleem-hadad/larecipe#390

GHSA-jv7x-xhv2-p5v2 is a critical-severity (CVSS 10) CWE-1336 vulnerability in binarytorch/larecipe. A fix is available for binarytorch/larecipe — see the affected versions and patch details below.

Also known asCVE-2025-53833
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
  • A successful exploit gives an attacker total control of the affected component, not partial access.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for GHSA-jv7x-xhv2-p5v2.

EPSS Exploitation Probability

via FIRST.org ↗
9.1%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs95th percentile — riskier than 95% of all scored CVEsHighest risk
5.64%11.9%18.1%24.3%16.8%9.1%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘binarytorch/larecipe

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Impact

Attackers could:

  1. Execute arbitrary commands on the server
  2. Access sensitive environment variables
  3. Escalate access depending on server configuration

A critical vulnerability was discovered in LaRecipe that allows an attacker to perform Server-Side Template Injection (SSTI), potentially leading to Remote Code Execution (RCE) in vulnerable configurations.

Patches

Users are strongly advised to upgrade to version v2.8.1 or later.

Credit

We would like to thank Roman Ananev for responsibly identifying and reporting this vulnerability.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistbinarytorch/larecipeall versions2.8.1composer require binarytorch/larecipe:^2.8.1

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for binarytorch/larecipe, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update binarytorch/larecipe to 2.8.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-jv7x-xhv2-p5v2 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

How to detect GHSA-jv7x-xhv2-p5v2

A community-maintained Nuclei template exists for this CVE. You can scan for it directly:

nuclei -id ghsa-jv7x-xhv2-p5v2 -u https://target
Template
LaRecipe < 2.8.1 Remote Code Execution via SSTI
Severity
critical
Impact
Attackers could execute arbitrary commands on the server, access sensitive environment variables, and/or escalate access depending on server configuration.
Remediation
Users are strongly advised to upgrade to version v2.8.1 or later to receive a patch.

Template by ProjectDiscovery nuclei-templates (iamnoooob, pdresearch), MIT licensed. View the full template. Scan only systems you are authorised to test.

Frequently Asked Questions

### Impact Attackers could: 1. Execute arbitrary commands on the server 2. Access sensitive environment variables 3. Escalate access depending on server configuration A critical vulnerability was discovered in LaRecipe that allows an attacker to perform Server-Side Template Injection (SSTI), potentially leading to Remote Code Execution (RCE) in vulnerable configurations. ### Patches Users are strongly advised to upgrade to version v2.8.1 or later. ### Credit We would like to thank **Roman Ananev** for responsibly identifying and reporting this vulnerability.
O3 Security · Impact-Aware SCA

Is GHSA-jv7x-xhv2-p5v2 in your dependencies?

Find it across Packagist, including transitive dependencies.

LaRecipe is vulnerable to Server-Side Template Injection…