NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
HIGH severity

dom-iterator code execution vulnerabilityGHSA-jrvm-mcxc-mf6m

HIGHFix: matthewmueller/dom-iterator@9e0e0fa

GHSA-jrvm-mcxc-mf6m is a high-severity (CVSS 7.3) Code Injection vulnerability in dom-iterator. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for dom-iterator — see the affected versions and patch details below.

Also known asCVE-2024-21541
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

Proof-of-concept exploit code exists

  • CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
  • CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.

Exploitation and automatability from CISA’s SSVC triage for GHSA-jrvm-mcxc-mf6m.

EPSS Exploitation Probability

via FIRST.org ↗
1.1%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs65th percentile — riskier than 65% of all scored CVEsHighest risk
0.00%0.53%1.05%1.58%0.3%1.1%May 26Aug 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

33other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
dom-iteratornpm
136Kdownloads / week

Description

Versions of the package dom-iterator before 1.0.1 are vulnerable to Arbitrary Code Execution due to use of the Function constructor without complete input sanitization. Function generates a new function body and thus care must be given to ensure that the inputs to Function are not attacker-controlled. The risks involved are similar to that of allowing attacker-controlled input to reach eval.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmdom-iteratorall versions1.0.1npm install dom-iterator@1.0.1

Affected Products

1 product · 1 configurations
Application
dom-iteratormatthewmueller
≤ 1.0.0
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for dom-iterator, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update dom-iterator to 1.0.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-jrvm-mcxc-mf6m is resolved across your whole dependency graph.

  3. Workarounds

    Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.

Frequently Asked Questions

Versions of the package dom-iterator before 1.0.1 are vulnerable to Arbitrary Code Execution due to use of the Function constructor without complete input sanitization. Function generates a new function body and thus care must be given to ensure that the inputs to Function are not attacker-controlled. The risks involved are similar to that of allowing attacker-controlled input to reach eval.
O3 Security · Impact-Aware SCA

Is GHSA-jrvm-mcxc-mf6m in your dependencies?

Find it across npm, including transitive dependencies.

GHSA-jrvm-mcxc-mf6m: dom-iterator RCE — Fixed in 1.0.1