NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
MEDIUM severity

Cross site scripting in parse-urlGHSA-jpp7-7chh-cf67

MEDIUMFix: ionicabizau/parse-url@21c72ab

GHSA-jpp7-7chh-cf67 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in parse-url. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for parse-url — see the affected versions and patch details below.

Also known asCVE-2022-2218
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 2, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.9%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs60th percentile — riskier than 60% of all scored CVEsHighest risk
0.00%0.47%0.94%1.41%0.3%0.9%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

462other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
parse-urlnpm
7.0Mdownloads / week

Description

Cross-site Scripting (XSS) - Stored in GitHub repository ionicabizau/parse-url prior to 7.0.0.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmparse-urlall versions6.0.1npm install parse-url@6.0.1

Affected Products

1 product · 1 configurations
Application
parse-urlparse-url_project
< 7.0.0
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for parse-url, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update parse-url to 6.0.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-jpp7-7chh-cf67 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Cross-site Scripting (XSS) - Stored in GitHub repository ionicabizau/parse-url prior to 7.0.0.
O3 Security · Impact-Aware SCA

Is GHSA-jpp7-7chh-cf67 in your dependencies?

Find it across npm, including transitive dependencies.

Cross site scripting in parse-url (Medium 6.1)