Akka.Remote TLS did not properly implement certificate-based authenticationGHSA-jhpv-4q4f-43g5
Fix: akkadotnet/akka.net#7847GHSA-jhpv-4q4f-43g5 is a CWE-290 vulnerability in Akka.Remote. A fix is available for Akka.Remote — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-jhpv-4q4f-43g5.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
Akka.Remote.NETAkka.ClusterReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects NuGet packages — download data is not available via public APIs for these ecosystems.
Description
Impact
This is a critical network security vulnerability for Akka.Remote users who have SSL / TLS enabled on their Akka.Remote connections and were expecting certificate-based authentication to be enforced on all peers attempting to join the network.
In all versions of Akka.Remote from v1.2.0 to v1.5.51, TLS could be enabled via our akka.remote.dot-netty.tcp transport and this would correctly enforce private key validation on the server-side of inbound connections. Akka.Remote, however, never asked the outbound-connecting client to present ITS certificate - therefore it's possible for untrusted parties to connect to a private key'd Akka.NET cluster and begin communicating with it without any certificate.
The issue here is that for certificate-based authentication to work properly, ensuring that all members of the Akka.Remote network are secured with the same private key, Akka.Remote needed to implement mutual TLS. This was not the case before Akka.NET v1.5.52.
If you are running Akka.NET inside a private network you fully control or you were never using TLS in the first place, then this bug has no impact on you. However: if you are using TLS to secure your network YOU MUST upgrade to Akka.NET V1.5.52 or later.
Patches
https://github.com/akkadotnet/akka.net/pull/7847 - forces "fail fast" semantics if TLS is enabled but the private key is missing or invalid. Previous versions would only check that once connection attempts occurred. https://github.com/akkadotnet/akka.net/pull/7851 - critical fix: enforces mutual TLS (mTLS) by default, so both parties must be keyed using the same certificate. This fulfills the original security
These updates have been shipped into Akka.NET v1.5.52: https://github.com/akkadotnet/akka.net/releases/tag/1.5.52
Workarounds
If your application isn't exposed publicly, then CVE-2025-61778 has no practical impact on your application. That being said: upgrading to Akka.NET v1.5.52 or later is a good idea.
References
Please view our latest network security documentation here: https://getakka.net/articles/remoting/security.html
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| .NETNuGet | Akka.Remote | ≥ 1.2.0&&< 1.5.52 | 1.5.52dotnet add package Akka.Remote --version 1.5.52 |
| .NETNuGet | Akka.Cluster | ≥ 1.2.0&&< 1.5.52 | 1.5.52dotnet add package Akka.Cluster --version 1.5.52 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for Akka.Remote, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update Akka.Remote to 1.5.52 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-jhpv-4q4f-43g5 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Frequently Asked Questions
Is GHSA-jhpv-4q4f-43g5 in your dependencies?
Find it across NuGet, including transitive dependencies.