Parse Server has a Cross-Site Scripting (XSS) vulnerability via Unescaped Mustache Template VariablesGHSA-jhgf-2h8h-ggxv
Fix: parse-community/parse-server#9985GHSA-jhgf-2h8h-ggxv is a Cross-site Scripting (XSS) vulnerability in parse-server. A fix is available for parse-server — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-jhgf-2h8h-ggxv.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
parse-servernpmDescription
Impact
A Reflected Cross-Site Scripting (XSS) vulnerability exists in Parse Server's password reset and email verification HTML pages.
Patches
The patch escapes user controlled values that are inserted into the HTML pages.
Workarounds
None.
Resources
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | parse-server | all versions | 8.6.1npm install parse-server@8.6.1 |
| 📦npm | parse-server | ≥ 9.0.0&&< 9.1.0-alpha.3 | 9.1.0-alpha.3npm install parse-server@9.1.0-alpha.3 |
Affected Products
parse-serverparseplatformDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for parse-server, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update parse-server to 8.6.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-jhgf-2h8h-ggxv is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is GHSA-jhgf-2h8h-ggxv in your dependencies?
Find it across npm, including transitive dependencies.