NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
MEDIUM severity

n8n has an Authentication Bypass in its Chat Trigger NodeGHSA-jh8h-6c9q-7gmw

MEDIUMFix: n8n-io/n8n@062644e

GHSA-jh8h-6c9q-7gmw is a medium-severity (CVSS 4.8) Improper Authentication vulnerability in n8n. A fix is available for n8n — see the affected versions and patch details below.

Also known asCVE-2026-56353
Published
Updated
Affected
3 pkgs
Patched
3 / 3
Exploits
None indexed
Exploitation data as of Oct 23, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for GHSA-jh8h-6c9q-7gmw.

EPSS Exploitation Probability

via FIRST.org ↗
0.3%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs25th percentile — riskier than 25% of all scored CVEsHighest risk
0.00%0.28%0.55%0.83%0.2%0.3%0.3%0.3%Aug 26Oct 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

3 pkgs affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

36other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
n8nnpm
80Kdownloads / week

Description

Impact

When the Chat Trigger node is configured with n8n User Auth authentication, the authentication check could be circumvented.

  • This issue requires the Chat Trigger node to be configured with n8n User Auth authentication (non-default).

Patches

The issue has been fixed in n8n versions 2.10.1, 2.9.3, and 1.123.22. Users should upgrade to one of these versions or later to remediate the vulnerability.

Workarounds

If upgrading is not immediately possible, administrators should consider the following temporary mitigations:

  • Limit workflow creation and editing permissions to fully trusted users only.
  • Use a different authentication method for the Chat Trigger node, or restrict network access to the webhook endpoint to trusted origins.

These workarounds do not fully remediate the risk and should only be used as short-term mitigation measures.

Affected Packages

3 total 3 fixed
EcosystemPackageVulnerable rangeFix
📦npmn8nall versions1.123.22npm install n8n@1.123.22
📦npmn8n≥ 2.0.0&&< 2.9.32.9.3npm install n8n@2.9.3
📦npmn8n≥ 2.10.0&&< 2.10.12.10.1npm install n8n@2.10.1

Affected Products

1 product · 4 configurations
Application
n8nn8n
≥ 2.0.0 && < 2.9.3
1 version
2.10.0

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for n8n, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update n8n to 1.123.22 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-jh8h-6c9q-7gmw is resolved across your whole dependency graph.

  3. Workarounds

    Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.

Frequently Asked Questions

## Impact When the Chat Trigger node is configured with n8n User Auth authentication, the authentication check could be circumvented. - This issue requires the Chat Trigger node to be configured with n8n User Auth authentication (non-default). ## Patches The issue has been fixed in n8n versions 2.10.1, 2.9.3, and 1.123.22. Users should upgrade to one of these versions or later to remediate the vulnerability. ## Workarounds If upgrading is not immediately possible, administrators should consider the following temporary mitigations: - Limit workflow creation and editing permissions to fully t
O3 Security · Impact-Aware SCA

Is GHSA-jh8h-6c9q-7gmw in your dependencies?

Find it across npm, including transitive dependencies.

n8n has an Authentication Bypass in its Chat Trigger Node