GHSA-jfmj-5v4g-7637 is a medium-severity (CVSS 6.2) CWE-835 vulnerability in zipp. A fix is available for zipp — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-jfmj-5v4g-7637.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
GHSA-jfmj-5v4g-7637 by exploitation likelihood (EPSS) against impact (CVSS). Outside the shaded patch-first corner.
Where this sits among everything scored
Of 395,492 CVEs with a current EPSS score, this one falls in the < 10% band (highlighted). Counts from FIRST.org, log-scaled.
Real-World Exposure
zippReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
A Denial of Service (DoS) vulnerability exists in the jaraco/zipp library, affecting all versions prior to 3.19.1. The vulnerability is triggered when processing a specially crafted zip file that leads to an infinite loop. This issue also impacts the zipfile module of CPython, as features from the third-party zipp library are later merged into CPython, and the affected code is identical in both projects. The infinite loop can be initiated through the use of functions affecting the Path module in both zipp and zipfile, such as joinpath, the overloaded division operator, and iterdir. Although the infinite loop is not resource exhaustive, it prevents the application from responding. The vulnerability was addressed in version 3.19.1 of jaraco/zipp.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | zipp | all versions | 3.19.1pip install --upgrade 'zipp==3.19.1' |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for zipp, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update zipp to 3.19.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-jfmj-5v4g-7637 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Ansible Automation Platform 2.4 for RHEL 8 | python3x-zipp-0:3.19.2-1.el8ap | RHSA-2024:6428 |
| Red Hat OpenShift Container Platform 4.16 | python-zipp-0:3.19.1-1.el9 | RHSA-2024:8418 |
| Red Hat OpenShift Container Platform 4.17 | python-zipp-0:3.19.1-1.el9 | RHSA-2024:8232 |
| Red Hat OpenStack Platform 17.1 for RHEL 9 | python-zipp-0:3.4.0-3.el9ost | RHSA-2024:9977 |
| Red Hat Satellite 6.16 for RHEL 8 | python-zipp-0:3.20.2-1.el8pc | RHSA-2024:8906 |
Frequently Asked Questions
Is GHSA-jfmj-5v4g-7637 in your dependencies?
Find it across PyPI, including transitive dependencies.