Drupal core Remote Code ExecutionGHSA-jf8c-36vw-98x4
GHSA-jf8c-36vw-98x4 is a remote code execution vulnerability in drupal/drupal. A fix is available for drupal/drupal — see the affected versions and patch details below.
Real-World Exposure
drupal/drupal🐘drupal/drupal🐘drupal/drupalReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
In Drupal core, when sending email some variables were not being sanitized for shell arguments in DefaultMailSystem::mail(), which could lead to remote code execution.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | drupal/drupal | ≥ 7.0&&< 7.60 | 7.60composer require drupal/drupal:^7.60 |
| 🐘Packagist | drupal/drupal | ≥ 8.0.0&&< 8.5.8 | 8.5.8composer require drupal/drupal:^8.5.8 |
| 🐘Packagist | drupal/drupal | ≥ 8.6.0&&< 8.6.2 | 8.6.2composer require drupal/drupal:^8.6.2 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for drupal/drupal, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update drupal/drupal to 7.60 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-jf8c-36vw-98x4 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is GHSA-jf8c-36vw-98x4 in your dependencies?
Find it across Packagist, including transitive dependencies.