OpenClaw safeBins jq `$ENV` filter bypass allows environment variable disclosureGHSA-jccr-rrw2-vc8h
HIGHFix: openclaw/openclaw@78e2f3dGHSA-jccr-rrw2-vc8h is a high-severity (CVSS 7.7) CWE-668 vulnerability in openclaw. A fix is available for openclaw — see the affected versions and patch details below.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
openclawnpmDescription
Summary
The jq safe-bin policy blocked explicit env usage but still allowed jq programs that accessed environment data through $ENV.
Impact
An operator-approved safe-bin jq command could disclose environment variables that the safe-bin policy was supposed to keep out of scope.
Affected Component
src/infra/exec-safe-bin-semantics.ts
Fixed Versions
- Affected:
<= 2026.3.24 - Patched:
>= 2026.3.28 - Latest stable
2026.3.28contains the fix.
Fix
Fixed by commit 78e2f3d66d (Exec: tighten jq safe-bin env checks).
Thanks @nicky-cc of Tencent zhuque Lab (https://github.com/Tencent/AI-Infra-Guard) for reporting.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | openclaw | all versions | 2026.3.28npm install openclaw@2026.3.28 |
Affected Products
openclawopenclawDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for openclaw, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update openclaw to 2026.3.28 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-jccr-rrw2-vc8h is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is GHSA-jccr-rrw2-vc8h in your dependencies?
Find it across npm, including transitive dependencies.