NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

Apache Shiro vulnerable to path traversalGHSA-jc7h-c423-mpjc

MEDIUM

GHSA-jc7h-c423-mpjc is a medium-severity (CVSS 6.5) Path Traversal vulnerability in org.apache.shiro:shiro-core. A fix is available for org.apache.shiro:shiro-core — see the affected versions and patch details below.

Also known asCVE-2023-46749
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 7, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for GHSA-jc7h-c423-mpjc.

EPSS Exploitation Probability

via FIRST.org ↗
1.2%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs68th percentile — riskier than 68% of all scored CVEsHighest risk
0.00%0.56%1.12%1.69%0.2%1.2%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
☕org.apache.shiro:shiro-core☕org.apache.shiro:shiro-core

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Apache Shiro before 1.13.0 or 2.0.0-alpha-4, may be susceptible to a path traversal attack that results in an authentication bypass when used together with path rewriting

Mitigation: Update to Apache Shiro 1.13.0+ or 2.0.0-alpha-4+, or ensure blockSemicolon is enabled (this is the default).

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.apache.shiro:shiro-coreall versions1.13.0org.apache.shiro:shiro-core:1.13.0
☕Mavenorg.apache.shiro:shiro-core≥ 2.0.0alpha1&&< 2.0.0-alpha42.0.0-alpha4org.apache.shiro:shiro-core:2.0.0-alpha4

Affected Products

1 product · 4 configurations
Application
shiroapache
< 1.13.0
1 version
2.0.0

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.shiro:shiro-core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.apache.shiro:shiro-core to 1.13.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-jc7h-c423-mpjc is resolved across your whole dependency graph.

  3. Workarounds

    Resolve every user-supplied path to its canonical form and reject anything that escapes the intended directory, and run the component under an account that has no read or write access outside the directory it legitimately serves.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate
Workaround published by Red Hat
This flaw can be mitigated by making sure 'blockSemicolon' is enabled.
Source: Red Hat security advisory for GHSA-jc7h-c423-mpjc (CC BY 4.0)
ProductFixed inAdvisory
Red Hat Fuse 7.13.0shiroRHSA-2024:3354

Frequently Asked Questions

Apache Shiro before 1.130 or 2.0.0-alpha-4, may be susceptible to a path traversal attack that results in an authentication bypass when used together with path rewriting Mitigation: Update to Apache Shiro 1.13.0+ or 2.0.0-alpha-4+, or ensure `blockSemicolon` is enabled (this is the default).
O3 Security · Impact-Aware SCA

Is GHSA-jc7h-c423-mpjc in your dependencies?

Find it across Maven, including transitive dependencies.

Apache Shiro vulnerable to path traversal (Medium 6.5)