Server classes and resources exposure in OSGi applications using Vaadin 12-14 and 19GHSA-j9wr-49vq-rm5g
HIGHGHSA-j9wr-49vq-rm5g is a high-severity (CVSS 8.6) vulnerability in com.vaadin:vaadin-bom. A fix is available for com.vaadin:vaadin-bom — see the affected versions and patch details below.
Real-World Exposure
com.vaadin:vaadin-bom☕com.vaadin:vaadin-bomReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Vulnerability in OSGi integration in com.vaadin:flow-server versions 1.2.0 through 2.4.7 (Vaadin 12.0.0 through 14.4.9), and 6.0.0 through 6.0.1 (Vaadin 19.0.0) allows attacker to access application classes and resources on the server via crafted HTTP request.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | com.vaadin:vaadin-bom | ≥ 12.0.0&&< 14.4.10 | 14.4.10com.vaadin:vaadin-bom:14.4.10 |
| ☕Maven | com.vaadin:vaadin-bom | ≥ 19.0.0&&< 19.0.1 | 19.0.1com.vaadin:vaadin-bom:19.0.1 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for com.vaadin:vaadin-bom, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update com.vaadin:vaadin-bom to 14.4.10 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-j9wr-49vq-rm5g is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is GHSA-j9wr-49vq-rm5g in your dependencies?
Find it across Maven, including transitive dependencies.