XWiki Platform vulnerable to RXSS via editor parameter - importinline templateGHSA-j9h5-vcgv-2jfm
CRITICALFix: xwiki/xwiki-platform@28905f7GHSA-j9h5-vcgv-2jfm is a critical-severity (CVSS 9) Cross-site Scripting (XSS) vulnerability in org.xwiki.platform:xwiki-platform-distribution-war. EPSS puts its 30-day exploitation probability at 70.4% (99th percentile). A fix is available for org.xwiki.platform:xwiki-platform-distribution-war — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- A successful exploit gives an attacker total control of the affected component, not partial access.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-j9h5-vcgv-2jfm.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.xwiki.platform:xwiki-platform-distribution-war☕org.xwiki.platform:xwiki-platform-distribution-warReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Impact
It's possible to execute javascript with the right of any user by leading him to a special URL on the wiki targeting a page which contains an attachment.
To reproduce:
- add an attachment to a page (for example, your user profile)
- add
?xpage=importinline&editor=%22%3E%3Cimg%20src%20onerror=alert(document.domain)%3Eto the page view URL as inhttps://myhost/xwiki/bin/view/XWiki/MyUser?xpage=importinline&editor=%22%3E%3Cimg%20src%20onerror=alert(document.domain)%3E
Patches
This has been patched in XWiki 15.0-rc-1, 14.10.4 and 14.4.8.
Workarounds
The easiest is to edit file <xwiki app>/templates/importinline.vm and apply the modification described on https://github.com/xwiki/xwiki-platform/commit/28905f7f518cc6f21ea61fe37e9e1ed97ef36f01
References
https://jira.xwiki.org/browse/XWIKI-20340 https://app.intigriti.com/company/submissions/e95a7ad5-7029-4627-abf0-3e3e3ea0b4ce/XWIKI-E93DFEYK
Attribution
This vulnerability has been reported on Intigriti by René de Sain @renniepak.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.xwiki.platform:xwiki-platform-distribution-war | ≥ 2.2-milestone-1&&< 14.4.8 | 14.4.8org.xwiki.platform:xwiki-platform-distribution-war:14.4.8 |
| ☕Maven | org.xwiki.platform:xwiki-platform-distribution-war | ≥ 14.5&&< 14.10.4 | 14.10.4org.xwiki.platform:xwiki-platform-distribution-war:14.10.4 |
Affected Products
xwikixwikiDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.xwiki.platform:xwiki-platform-distribution-war, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.xwiki.platform:xwiki-platform-distribution-war to 14.4.8 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-j9h5-vcgv-2jfm is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is GHSA-j9h5-vcgv-2jfm in your dependencies?
Find it across Maven, including transitive dependencies.