NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

Moodle allows users to retrieve information they did not have permission to accessGHSA-j822-x5gg-5r56

MEDIUMFix: moodle/moodle@bb466df

GHSA-j822-x5gg-5r56 is a medium-severity (CVSS 6.5) CWE-862 vulnerability in moodle/moodle. A fix is available for moodle/moodle — see the affected versions and patch details below.

Also known asBIT-moodle-2024-45689CVE-2024-45689
Published
Updated
Affected
4 pkgs
Patched
4 / 4
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for GHSA-j822-x5gg-5r56.

EPSS Exploitation Probability

via FIRST.org ↗
0.4%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs34th percentile — riskier than 34% of all scored CVEsHighest risk
0.00%0.30%0.60%0.90%0.1%0.4%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

4 pkgs affected
🐘moodle/moodle🐘moodle/moodle🐘moodle/moodle🐘moodle/moodle

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

A flaw was found in Moodle. Dynamic tables did not enforce capability checks, which resulted in users having the ability to retrieve information they did not have permission to access.

Affected Packages

4 total 4 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistmoodle/moodleall versions4.1.13composer require moodle/moodle:^4.1.13
🐘Packagistmoodle/moodle≥ 4.2.0-beta&&< 4.2.104.2.10composer require moodle/moodle:^4.2.10
🐘Packagistmoodle/moodle≥ 4.3.0-beta&&< 4.3.74.3.7composer require moodle/moodle:^4.3.7
🐘Packagistmoodle/moodle≥ 4.4.0-beta&&< 4.4.34.4.3composer require moodle/moodle:^4.4.3

Affected Products

1 product · 4 configurations
Application
moodlemoodle
≥ 4.4.0 && < 4.4.3
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for moodle/moodle, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update moodle/moodle to 4.1.13 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-j822-x5gg-5r56 is resolved across your whole dependency graph.

  3. Workarounds

    Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.

Frequently Asked Questions

A flaw was found in Moodle. Dynamic tables did not enforce capability checks, which resulted in users having the ability to retrieve information they did not have permission to access.
O3 Security · Impact-Aware SCA

Is GHSA-j822-x5gg-5r56 in your dependencies?

Find it across Packagist, including transitive dependencies.

Moodle allows users to retrieve information they did not…