NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
HIGH severity

Pillow is vulnerable to Denial of Service (DOS) in the Jpeg2KImagePluginGHSA-j6f7-g425-4gmx

HIGHFix: python-pillow/Pillow@347a1d8

GHSA-j6f7-g425-4gmx is a high-severity (CVSS 7.5) CWE-399 vulnerability in pillow. A fix is available for pillow — see the affected versions and patch details below.

Also known asCVE-2014-3598PYSEC-2015-15
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.0%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs81th percentile — riskier than 81% of all scored CVEsHighest risk
0.00%0.83%1.66%2.49%0.4%2.0%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍pillow

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

The Jpeg2KImagePlugin plugin in Pillow before 2.5.3 allows remote attackers to cause a denial of service via a crafted image.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIpillowall versions2.5.3pip install --upgrade 'pillow==2.5.3'

Affected Products

2 products · 2 configurations
OS
opensuseopensuse
1 version
13.2
Application
pillowpython
≤ 2.5.2
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for pillow, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update pillow to 2.5.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-j6f7-g425-4gmx is resolved across your whole dependency graph.

  3. Workarounds

    Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.

Frequently Asked Questions

The Jpeg2KImagePlugin plugin in Pillow before 2.5.3 allows remote attackers to cause a denial of service via a crafted image.
O3 Security · Impact-Aware SCA

Is GHSA-j6f7-g425-4gmx in your dependencies?

Find it across PyPI, including transitive dependencies.

Pillow is vulnerable to Denial of Service (DOS) in the…