NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
HIGH severity

Drupal core Arbitrary PHP code executionGHSA-j66p-fvp2-fxhj

HIGH

GHSA-j66p-fvp2-fxhj is a high-severity (CVSS 7.8) vulnerability in drupal/drupal. A fix is available for drupal/drupal — see the affected versions and patch details below.

Published
Updated
Affected
4 pkgs
Patched
4 / 4
Exploits
None indexed
Exploitation data as of Nov 29, 2024 · OSV.dev, FIRST.org (EPSS)

Real-World Exposure

4 pkgs affected
🐘drupal/drupal🐘drupal/drupal🐘drupal/drupal🐘drupal/drupal

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

The Drupal project uses the PEAR Archive_Tar library. The PEAR Archive_Tar library has released a security update that impacts Drupal. For more information please see: CVE-2020-28948 CVE-2020-28949

Multiple vulnerabilities are possible if Drupal is configured to allow .tar, .tar.gz, .bz2, or .tlz file uploads and processes them.

To mitigate this issue, prevent untrusted users from uploading .tar, .tar.gz, .bz2, or .tlz files.

Affected Packages

4 total 4 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistdrupal/drupal≥ 7.0.0&&< 7.757.75composer require drupal/drupal:^7.75
🐘Packagistdrupal/drupal≥ 8.0.0&&< 8.8.128.8.12composer require drupal/drupal:^8.8.12
🐘Packagistdrupal/drupal≥ 8.9.0&&< 8.9.108.9.10composer require drupal/drupal:^8.9.10
🐘Packagistdrupal/drupal≥ 9.0.0&&< 9.0.99.0.9composer require drupal/drupal:^9.0.9

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for drupal/drupal, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update drupal/drupal to 7.75 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-j66p-fvp2-fxhj is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

The Drupal project uses the PEAR Archive_Tar library. The PEAR Archive_Tar library has released a security update that impacts Drupal. For more information please see: CVE-2020-28948 CVE-2020-28949 Multiple vulnerabilities are possible if Drupal is configured to allow .tar, .tar.gz, .bz2, or .tlz file uploads and processes them. To mitigate this issue, prevent untrusted users from uploading .tar, .tar.gz, .bz2, or .tlz files.
O3 Security · Impact-Aware SCA

Is GHSA-j66p-fvp2-fxhj in your dependencies?

Find it across Packagist, including transitive dependencies.

Drupal core Arbitrary PHP code execution (High 7.8)