NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
CRITICAL severity

XWiki allows remote code execution through the extension sheetGHSA-j2pq-22jj-4pm5

CRITICALFix: xwiki/xwiki-platform@8659f17

GHSA-j2pq-22jj-4pm5 is a critical-severity (CVSS 9.9) CWE-96 vulnerability in org.xwiki.platform:xwiki-platform-repository-server-ui. A fix is available for org.xwiki.platform:xwiki-platform-repository-server-ui — see the affected versions and patch details below.

Also known asCVE-2024-55662
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

Proof-of-concept exploit code exists

  • CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
  • A successful exploit gives an attacker total control of the affected component, not partial access.

Exploitation and automatability from CISA’s SSVC triage for GHSA-j2pq-22jj-4pm5.

EPSS Exploitation Probability

via FIRST.org ↗
0.8%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs56th percentile — riskier than 56% of all scored CVEsHighest risk
0.00%5.46%10.9%16.4%9.8%0.8%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
☕org.xwiki.platform:xwiki-platform-repository-server-ui☕org.xwiki.platform:xwiki-platform-repository-server-ui

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Impact

On instances where Extension Repository Application is installed, any user can execute any code requiring programming rights on the server. In order to reproduce on an instance, as a normal user without script nor programming rights, go to your profile and add an object of type ExtensionCode.ExtensionClass. Set the description to {{async}}{{groovy}}println("Hello from Description"){{/groovy}}{{/async}} and press Save and View. If the description displays as Hello from Description without any error, then the instance is vulnerable.

Patches

This vulnerability has been fixed in XWiki 15.10.9 and 16.3.0.

Workarounds

Since Extension Repository Application is not mandatory, it can be safely disabled on instances that do not use it. It is also possible to manually apply this patch to the page ExtensionCode.ExtensionSheet, as well as this patch to the page ExtensionCode.ExtensionAuthorsDisplayer.

References

For more information

If you have any questions or comments about this advisory:

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.xwiki.platform:xwiki-platform-repository-server-ui≥ 3.3-milestone-1&&< 15.10.915.10.9org.xwiki.platform:xwiki-platform-repository-server-ui:15.10.9
☕Mavenorg.xwiki.platform:xwiki-platform-repository-server-ui≥ 16.0.0-rc-1&&< 16.3.016.3.0org.xwiki.platform:xwiki-platform-repository-server-ui:16.3.0

Affected Products

1 product · 2 configurations
Application
xwikixwiki
≥ 16.0.0 && < 16.3.0
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.xwiki.platform:xwiki-platform-repository-server-ui, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.xwiki.platform:xwiki-platform-repository-server-ui to 15.10.9 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-j2pq-22jj-4pm5 is resolved across your whole dependency graph.

  3. Workarounds

    Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.

Frequently Asked Questions

### Impact On instances where `Extension Repository Application` is installed, any user can execute any code requiring `programming` rights on the server. In order to reproduce on an instance, as a normal user without `script` nor `programming` rights, go to your profile and add an object of type `ExtensionCode.ExtensionClass`. Set the description to `{{async}}{{groovy}}println("Hello from Description"){{/groovy}}{{/async}}` and press `Save and View`. If the description displays as `Hello from Description` without any error, then the instance is vulnerable. ### Patches This vulnerability has
O3 Security · Impact-Aware SCA

Is GHSA-j2pq-22jj-4pm5 in your dependencies?

Find it across Maven, including transitive dependencies.

XWiki allows remote code execution through the…