namshi/jose insecure JSON Web Signatures (JWS)GHSA-hxhc-wmg8-xrqf
Fix: namshi/jose@009f86dGHSA-hxhc-wmg8-xrqf is a security vulnerability in namshi/jose. A fix is available for namshi/jose — see the affected versions and patch details below.
Real-World Exposure
namshi/jose🐘namshi/jose🐘namshi/jose🐘namshi/joseReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
namshi/jose allows the acceptance of unsecure JSON Web Signatures (JWS) by default. The vulnerability arises from the $allowUnsecure flag, which, when set to true during the loading of JWSes, permits tokens signed with 'none' algorithms to be processed. This behavior poses a significant security risk as it could allow an attacker to impersonate users by crafting a valid jwt token.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | namshi/jose | all versions | 1.1.2composer require namshi/jose:^1.1.2 |
| 🐘Packagist | namshi/jose | ≥ 1.2.0&&< 1.2.2 | 1.2.2composer require namshi/jose:^1.2.2 |
| 🐘Packagist | namshi/jose | ≥ 2.0.0&&< 2.0.3 | 2.0.3composer require namshi/jose:^2.0.3 |
| 🐘Packagist | namshi/jose | ≥ 2.1.0&&< 2.1.2 | 2.1.2composer require namshi/jose:^2.1.2 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for namshi/jose, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update namshi/jose to 1.1.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-hxhc-wmg8-xrqf is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is GHSA-hxhc-wmg8-xrqf in your dependencies?
Find it across Packagist, including transitive dependencies.