Write access to the catalog for any user when restricted-admin role is enabled in RancherGHSA-hx8w-ghh8-r4xf
HIGHGHSA-hx8w-ghh8-r4xf is a high-severity (CVSS 8.1) Improper Privilege Management vulnerability in github.com/rancher/rancher. A fix is available for github.com/rancher/rancher — see the affected versions and patch details below.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
github.com/rancher/rancher🐹github.com/rancher/rancherReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.
Description
Impact
This vulnerability only affects customers using the restricted-admin role in Rancher. For this role to be active, Rancher must be bootstrapped with the environment variable CATTLE_RESTRICTED_DEFAULT_ADMIN=true or the configuration flag restrictedAdmin=true.
A flaw was discovered in Rancher versions from 2.5.0 up to and including 2.5.12 and from 2.6.0 up to and including 2.6.3 where the global-data role in cattle-global-data namespace grants write access to the Catalogs. Since each user with any level of catalog access was bound to the global-data role, this grants write access to templates (CatalogTemplates) and template versions (CatalogTemplateVersions) for any user with any level of catalog access. New users created in Rancher are by default assigned to the user role (standard user), which is not designed to grant write catalog access. This vulnerability effectively elevates the privilege of any user to write access for the catalog template and catalog template version resources.
A malicious user could abuse this vulnerability to:
- Make applications or individual versions of applications visible or hidden on the UI, by modifying
versionandrancherMaxVersionfields. - Change the logo (field
icon) of an application or template to an arbitrary image. - Make a chart appear as a trusted or partner chart. This can be abused to make less trusted charts, such as customer defined charts, appear more legitimate than they are, by adding the label
io.rancher.certified: partner. - Swap template versions between templates of charts inside the same catalog. This can be exploited to swap the files from one chart or version to another, by changing
versionDirfield. When a user on the target cluster deploys their chart, it will deploy the modified version.
This vulnerability does not allow to modify the base64 encoded files fields of the templateVersions, so one cannot inject arbitrary data to charts that have already been pulled from their respective catalog.
Without access to the Catalog, malicious users are limited to injecting apps which already exist in a registered catalog. They would need write access to the catalog or external write access to a source repo to inject arbitrary code.
Patches
Patched versions include releases 2.5.13, 2.6.4 and later versions.
Workarounds
Limit access in Rancher to trusted users. There is not a direct mitigation besides upgrading to the patched Rancher versions.
Note: If you use the restricted-admin as the default admin role in your environment, it's highly advised to review CatalogTemplates and CatalogTemplateVersions for possible malicious modifications.
For more information
If you have any questions or comments about this advisory:
- Reach out to SUSE Rancher Security team for security related inquiries.
- Open an issue in Rancher repository.
- Verify our support matrix and product support lifecycle.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐹Go | github.com/rancher/rancher | ≥ 2.6.0&&< 2.6.4 | 2.6.4go get github.com/rancher/rancher@v2.6.4 |
| 🐹Go | github.com/rancher/rancher | ≥ 2.5.0&&< 2.5.13 | 2.5.13go get github.com/rancher/rancher@v2.5.13 |
Affected Products
ranchersuseDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/rancher/rancher, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update github.com/rancher/rancher to 2.6.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-hx8w-ghh8-r4xf is resolved across your whole dependency graph.
Workarounds
Close the privilege gap rather than the entry point: audit which accounts, roles and service identities can reach the affected operation, drop the component to the least privilege it actually needs, and review file and directory permissions created by earlier installs — a default left in place is what makes this reachable.
Frequently Asked Questions
Is GHSA-hx8w-ghh8-r4xf in your dependencies?
Find it across Go, including transitive dependencies.