SAML authentication bypass due to missing validation on unsigned SAML messagesGHSA-hx5q-v6pj-533r
CRITICALFix: line/centraldogma@1690342GHSA-hx5q-v6pj-533r is a critical-severity (CVSS 9.1) vulnerability in com.linecorp.centraldogma:centraldogma-server-auth-saml. A fix is available for com.linecorp.centraldogma:centraldogma-server-auth-saml — see the affected versions and patch details below.
Real-World Exposure
com.linecorp.centraldogma:centraldogma-server-auth-samlReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Impact
When SAML is used as the authentication mechanism, Central Dogma accepts unsigned SAML messages (assertions, logout requests, etc.) as they are, rather than rejecting them by default. As a result, an attacker can forge a SAML message to authenticate themselves, despite the fact that such an unsigned SAML message should be rejected.
Patches
The vulnerability has been patched in Central Dogma 0.64.3 by updating its Armeria dependency to 1.27.2. All users who use SAML as the authentication mechanism must upgrade from 0.64.3 or later.
Workarounds
A user can manually upgrade the armeria-saml module with the one from Armeria 1.27.2 or later, either by replacing the JAR in the Central Dogma distribution or by updating the dependency tree of the build.
References
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | com.linecorp.centraldogma:centraldogma-server-auth-saml | all versions | 0.64.3com.linecorp.centraldogma:centraldogma-server-auth-saml:0.64.3 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for com.linecorp.centraldogma:centraldogma-server-auth-saml, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update com.linecorp.centraldogma:centraldogma-server-auth-saml to 0.64.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-hx5q-v6pj-533r is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is GHSA-hx5q-v6pj-533r in your dependencies?
Find it across Maven, including transitive dependencies.