HashiCorp Vault's PKI mount vulnerable to denial of serviceGHSA-hwc3-3qh6-r4gg
MEDIUMGHSA-hwc3-3qh6-r4gg is a medium-severity (CVSS 6.5) CWE-285 vulnerability in github.com/hashicorp/vault. A fix is available for github.com/hashicorp/vault — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-hwc3-3qh6-r4gg.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
github.com/hashicorp/vault🐹github.com/hashicorp/vault🐹github.com/hashicorp/vaultReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.
Description
HashiCorp Vault's PKI mount issuer endpoints did not correctly authorize access to remove an issuer or modify issuer metadata, potentially resulting in denial of service of the PKI mount. This bug did not affect public or private key material, trust chains or certificate issuance. Fixed in Vault 1.13.1, 1.12.5, and 1.11.9.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐹Go | github.com/hashicorp/vault | all versions | 1.11.9go get github.com/hashicorp/vault@v1.11.9 |
| 🐹Go | github.com/hashicorp/vault | ≥ 1.12.0&&< 1.12.5 | 1.12.5go get github.com/hashicorp/vault@v1.12.5 |
| 🐹Go | github.com/hashicorp/vault | ≥ 1.13.0&&< 1.13.1 | 1.13.1go get github.com/hashicorp/vault@v1.13.1 |
Affected Products
vaulthashicorpDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/hashicorp/vault, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update github.com/hashicorp/vault to 1.11.9 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-hwc3-3qh6-r4gg is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat OpenShift Container Platform 4.13 | openshift4/ose-installer:v4.13.0-202305091542.p0.g44db7b2.assembly.stream | RHSA-2023:1326 |
| Red Hat OpenShift Container Platform 4.14 | openshift4/ose-installer:v4.14.0-202310201027.p0.g03546e5.assembly.stream | RHSA-2023:5006 |
| RHODF-4.13-RHEL-9 | odf4/odf-rhel9-operator:v4.13.0-24 | RHSA-2023:3742 |
Frequently Asked Questions
Is GHSA-hwc3-3qh6-r4gg in your dependencies?
Find it across Go, including transitive dependencies.