NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
💎 RubyGems
Not in CISA KEV

omniauth-saml has dependency on ruby-saml version with Signature Wrapping Attack issueGHSA-hw46-3hmr-x9xv

Fix: omniauth/omniauth-saml@0d5eaa0

GHSA-hw46-3hmr-x9xv is a security vulnerability in omniauth-saml. A fix is available for omniauth-saml — see the affected versions and patch details below.

Published
Updated
Affected
3 pkgs
Patched
3 / 3
Exploits
None indexed
Exploitation data as of Feb 4, 2026 · OSV.dev, FIRST.org (EPSS)

Real-World Exposure

3 pkgs affected
💎omniauth-saml💎omniauth-saml💎omniauth-saml

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects RubyGems packages — download data is not available via public APIs for these ecosystems.

Description

Summary

There are 2 new Critical Signature Wrapping Vulnerabilities (CVE-2025-25292, CVE-2025-25291) and a potential DDOS Moderated Vulneratiblity (CVE-2025-25293) affecting ruby-saml, a dependency of omniauth-saml.

The fix will be applied to ruby-saml and released 12 March 2025, under version 1.18.0.

Please upgrade the ruby-saml requirement to v1.18.0.

Impact

Signature Wrapping Vulnerabilities allows an attacker to impersonate a user.

Affected Packages

3 total 3 fixed
EcosystemPackageVulnerable rangeFix
💎RubyGemsomniauth-saml≥ 2.2.0&&< 2.2.32.2.3bundle update omniauth-saml --conservative
💎RubyGemsomniauth-saml≥ 2.0.0&&< 2.1.32.1.3bundle update omniauth-saml --conservative
💎RubyGemsomniauth-samlall versions1.10.6bundle update omniauth-saml --conservative

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for omniauth-saml, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update omniauth-saml to 2.2.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-hw46-3hmr-x9xv is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

### Summary There are 2 new Critical Signature Wrapping Vulnerabilities (CVE-2025-25292, CVE-2025-25291) and a potential DDOS Moderated Vulneratiblity (CVE-2025-25293) affecting ruby-saml, a dependency of omniauth-saml. The fix will be applied to ruby-saml and released 12 March 2025, under version 1.18.0. Please [upgrade](https://github.com/omniauth/omniauth-saml/blob/master/omniauth-saml.gemspec#L16) the ruby-saml requirement to v1.18.0. ### Impact Signature Wrapping Vulnerabilities allows an attacker to impersonate a user.
O3 Security · Impact-Aware SCA

Is GHSA-hw46-3hmr-x9xv in your dependencies?

Find it across RubyGems, including transitive dependencies.

omniauth-saml has dependency on ruby-saml version…