OpenClaw Hook Session Key Override Enables Targeted Cross-Session RoutingGHSA-hv93-r4j3-q65f
HIGHFix: openclaw/openclaw@113ebfdGHSA-hv93-r4j3-q65f is a high-severity (CVSS 7.1) vulnerability in openclaw. A fix is available for openclaw — see the affected versions and patch details below.
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
openclawnpmDescription
Summary
The issue is not deterministic session keys by itself. The exploitable path was accepting externally supplied sessionKey values on authenticated hook ingress, allowing a hook token holder to route messages into chosen sessions.
Affected Behavior
POST /hooks/agentaccepted payloadsessionKeyand used it directly for session routing.- Common session-key shapes (for example
agent:main:dm:<peerId>) were often derivable from known metadata, making targeted routing practical when request-level override was enabled.
Attack Preconditions
- Attacker can call hook endpoints with a valid hook token.
- Hook ingress allows request-selected
sessionKeyvalues. - Target session keys can be derived or guessed.
Without those preconditions, deterministic key formats alone do not provide access.
Impact
- Integrity: targeted message/prompt injection into chosen sessions.
- Persistence: poisoned context can affect subsequent turns when the same session key is reused.
- Confidentiality impact is secondary and depends on additional weaknesses.
Affected Versions
openclaw>= 2.0.0-beta3and< 2026.2.12
Patched Versions
openclaw>= 2026.2.12
Fix
OpenClaw now uses secure defaults for hook session routing:
POST /hooks/agentrejects payloadsessionKeyunlesshooks.allowRequestSessionKey=true.- Added
hooks.defaultSessionKeyfor fixed ingress routing. - Added
hooks.allowedSessionKeyPrefixesto constrain explicit routing keys. - Security audit warns on unsafe hook session-routing settings.
Recommended Configuration
{
"hooks": {
"enabled": true,
"token": "${OPENCLAW_HOOKS_TOKEN}",
"defaultSessionKey": "hook:ingress",
"allowRequestSessionKey": false,
"allowedSessionKeyPrefixes": ["hook:"]
}
}
Credit
Thanks @alpernae for responsible reporting.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | openclaw | ≥ 2.0.0-beta3&&< 2026.2.12 | 2026.2.12npm install openclaw@2026.2.12 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for openclaw, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update openclaw to 2026.2.12 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-hv93-r4j3-q65f is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is GHSA-hv93-r4j3-q65f in your dependencies?
Find it across npm, including transitive dependencies.