NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
HIGH severity

Reflected cross-site scripting (XSS) vulnerabilityGHSA-hrgx-7j6v-xj82

HIGHFix: keystonejs/keystone@96bf833

GHSA-hrgx-7j6v-xj82 is a high-severity (CVSS 7.1) Cross-site Scripting (XSS) vulnerability in @keystone-6/auth. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for @keystone-6/auth — see the affected versions and patch details below.

Also known asCVE-2022-0087
Published
Updated
Affected
2 pkgs
Patched
1 / 2
Exploits
1 known
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.8%probability of exploitation in next 30 days
Lower Risk+0.15%
Lower risk than most CVEs86th percentile — riskier than 86% of all scored CVEsHighest risk
0.00%24.1%48.1%72.2%56.1%2.8%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

4other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
@keystone-6/authnpm
20Kdownloads / week
@keystone-next/authnpm
126downloads / week

Description

This security advisory relates to a capability for an attacker to exploit a reflected cross-site scripting vulnerability when using the @keystone-6/auth package.

Impact

The vulnerability can impact users of the administration user interface when following an untrusted link to the signin or init page. This is a targeted attack and may present itself in the form of phishing and or chained in conjunction with some other vulnerability.

Vulnerability mitigation

Please upgrade to @keystone-6/auth >= 1.0.2, where this vulnerability has been closed. If you are using @keystone-next/auth, we strongly recommend you upgrade to @keystone-6.

Workarounds

If for some reason you cannot upgrade the dependencies in software, you could alternatively

  • disable the administration user interface, or
  • if using a reverse-proxy, strip query parameters when accessing the administration interface

References

https://owasp.org/www-community/attacks/xss/

Thanks to Shivansh Khari (@Shivansh-Khari) for discovering and reporting this vulnerability

Affected Packages

2 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npm@keystone-6/authall versions1.0.2npm install @keystone-6/auth@1.0.2
📦npm@keystone-next/authall versionsNo fix

Affected Products

1 product · 1 configurations
Application
keystonekeystonejs
< 1.0.2
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for @keystone-6/auth, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update @keystone-6/auth to 1.0.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-hrgx-7j6v-xj82 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

How to detect GHSA-hrgx-7j6v-xj82

A community-maintained Nuclei template exists for this CVE. You can scan for it directly:

nuclei -id ghsa-hrgx-7j6v-xj82 -u https://target
Template
Keystone 6 Login Page - Open Redirect and Cross-Site Scripting
Severity
medium
Impact
Attackers can redirect users to malicious websites or inject malicious JavaScript via the from parameter, potentially facilitating phishing attacks or stealing user credentials.
Remediation
Please upgrade to @keystone-6/auth >= 1.0.2, where this vulnerability has been closed. If you are using @keystone-next/auth, we strongly recommend you upgrade to @keystone-6

Template by ProjectDiscovery nuclei-templates (ShivanshKhari), MIT licensed. View the full template. Scan only systems you are authorised to test.

Frequently Asked Questions

This security advisory relates to a capability for an attacker to exploit a reflected cross-site scripting vulnerability when using the `@keystone-6/auth` package. #### Impact The vulnerability can impact users of the administration user interface when following an untrusted link to the `signin` or `init` page. This is a targeted attack and may present itself in the form of phishing and or chained in conjunction with some other vulnerability. ## Vulnerability mitigation Please upgrade to `@keystone-6/auth >= 1.0.2`, where this vulnerability has been closed. If you are using `@keystone-next/a
O3 Security · Impact-Aware SCA

Is GHSA-hrgx-7j6v-xj82 in your dependencies?

Find it across npm, including transitive dependencies.

Reflected cross-site scripting (XSS) vulnerability (High 7.1)