TYPO3 Denial of Service in Frontend Record RegistrationGHSA-hjx5-v9xg-7h25
HIGHFix: TYPO3-CMS/core@5a44f93GHSA-hjx5-v9xg-7h25 is a high-severity (CVSS 7.5) vulnerability in typo3/cms-core. A fix is available for typo3/cms-core — see the affected versions and patch details below.
Real-World Exposure
typo3/cms-core🐘typo3/cms-coreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
TYPO3’s built-in record registration functionality (aka “basic shopping cart”) using recs URL parameters is vulnerable to denial of service. Failing to properly ensure that anonymous user sessions are valid, attackers can use this vulnerability in order to create an arbitrary amount of individual session-data records in the database.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | typo3/cms-core | ≥ 8.0.0&&< 8.7.21 | 8.7.21composer require typo3/cms-core:^8.7.21 |
| 🐘Packagist | typo3/cms-core | ≥ 7.0.0&&< 7.6.32 | 7.6.32composer require typo3/cms-core:^7.6.32 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for typo3/cms-core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update typo3/cms-core to 8.7.21 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-hjx5-v9xg-7h25 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Frequently Asked Questions
Is GHSA-hjx5-v9xg-7h25 in your dependencies?
Find it across Packagist, including transitive dependencies.