GHSA-hf5p-f83x-5q2g is a medium-severity (CVSS 5.3) CWE-863 vulnerability in org.opennms:opennms-webapp-rest. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for org.opennms:opennms-webapp-rest — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-hf5p-f83x-5q2g.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.opennms:opennms-webapp-restReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
In OpenNMS Horizon 31.0.8 and versions earlier than 32.0.2 and related Meridian versions, any user that has the ROLE_FILESYSTEM_EDITOR can easily escalate their privileges to ROLE_ADMIN or any other role. The solution is to upgrade to Meridian 2023.1.5 or Horizon 32.0.2 or newer. Meridian and Horizon installation instructions state that they are intended for installation within an organization's private networks and should not be directly accessible from the Internet. OpenNMS thanks Erik Wynter for reporting this issue.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.opennms:opennms-webapp-rest | ≥ 31.0.8&&< 32.0.2 | 32.0.2org.opennms:opennms-webapp-rest:32.0.2 |
Affected Products
horizonopennmsmeridianopennmsResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.opennms:opennms-webapp-rest, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.opennms:opennms-webapp-rest to 32.0.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-hf5p-f83x-5q2g is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Frequently Asked Questions
Is GHSA-hf5p-f83x-5q2g in your dependencies?
Find it across Maven, including transitive dependencies.