plone.restapi vulnerable to Stored Cross Site Scripting with SVG image in user portraitGHSA-hc5c-r8m5-2gfh
LOWFix: plone/plone.restapi@5f44c23GHSA-hc5c-r8m5-2gfh is a low-severity (CVSS 3.7) vulnerability in plone-restapi. A fix is available for plone-restapi — see the affected versions and patch details below.
Real-World Exposure
plone-restapiReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
Impact
There is a stored cross site scripting vulnerability for SVG images uploaded in user portraits.
Note that a page that uses an image tag with an SVG image as source is never vulnerable, even when the SVG image contains malicious code. To exploit the vulnerability, an attacker would first need to upload an SVG image as user portrait, and then trick a user into following a link to this portrait.
Patches
A patch will be released in plone.restapi 8.43.3. This version is good for Plone 6.0, and for Plone 5.2 on Python 3.
In plone.restapi 7 or earlier there was no @portrait endpoint yet, so there is nothing to fix in that version. It is still vulnerable to this attack, and needs a fix in Zope 4. These two vulnerabilities share the same CVE: CVE-2023-42458.
Workarounds
You could remove the portrait field from the member data schema, and possibly remove all portraits that are already in the database, but this seems a bit drastic.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | plone-restapi | ≥ 8.0.0&&< 8.43.3 | 8.43.3pip install --upgrade 'plone-restapi==8.43.3' |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for plone-restapi, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update plone-restapi to 8.43.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-hc5c-r8m5-2gfh is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is GHSA-hc5c-r8m5-2gfh in your dependencies?
Find it across PyPI, including transitive dependencies.