NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
MEDIUM severity

pyLoad vulnerable to Improper Restriction of Rendered UI Layers or FramesGHSA-h8r9-467r-vjjf

MEDIUMFix: pyload/pyload@bd2a31b

GHSA-h8r9-467r-vjjf is a medium-severity (CVSS 6.1) CWE-1021 vulnerability in pyload-ng. A fix is available for pyload-ng — see the affected versions and patch details below.

Also known asCVE-2023-0057PYSEC-2026-904
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 7, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

Proof-of-concept exploit code exists

  • CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.

Exploitation and automatability from CISA’s SSVC triage for GHSA-h8r9-467r-vjjf.

EPSS Exploitation Probability

via FIRST.org ↗
0.5%probability of exploitation in next 30 days
Lower Risk+0.02%
Lower risk than most CVEs43th percentile — riskier than 43% of all scored CVEsHighest risk
0.00%0.46%0.92%1.38%0.9%0.5%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍pyload-ng

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

Improper Restriction of Rendered UI Layers or Frames in GitHub repository pyload/pyload prior to 0.5.0b3.dev33.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIpyload-ngall versions0.5.0b3.dev33pip install --upgrade 'pyload-ng==0.5.0b3.dev33'

Affected Products

2 products · 2 configurations
Application
pyloadpyload
< 2023-01-05
range
Application
pyload-ngpyload-ng_project
< 0.5.0b3.dev33
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for pyload-ng, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update pyload-ng to 0.5.0b3.dev33 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-h8r9-467r-vjjf is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

Improper Restriction of Rendered UI Layers or Frames in GitHub repository pyload/pyload prior to 0.5.0b3.dev33.
O3 Security · Impact-Aware SCA

Is GHSA-h8r9-467r-vjjf in your dependencies?

Find it across PyPI, including transitive dependencies.

pyLoad vulnerable to Improper Restriction of Rendered UI…