NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
HIGH severity

scheb/two-factor-bundle bypass two-factor authentication with unverified JWT trusted device tokenGHSA-h6mp-mc7g-mg49

HIGHFix: scheb/two-factor-bundle@8890c1e

GHSA-h6mp-mc7g-mg49 is a high-severity (CVSS 7.4) vulnerability in scheb/two-factor-bundle. A fix is available for scheb/two-factor-bundle — see the affected versions and patch details below.

Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Dec 6, 2024 · OSV.dev, FIRST.org (EPSS)

Real-World Exposure

1 pkg affected
🐘scheb/two-factor-bundle

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Before version 3.7 the bundle is vulnerable to a security issue in JWT, which can be exploited by an attacker to generate trusted device cookies on their own, effectively by-passing two-factor authentication.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistscheb/two-factor-bundle≥ 3.0.0&&< 3.7.03.7.0composer require scheb/two-factor-bundle:^3.7.0

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for scheb/two-factor-bundle, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update scheb/two-factor-bundle to 3.7.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-h6mp-mc7g-mg49 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

Before version 3.7 the bundle is vulnerable to a [security issue in JWT](https://auth0.com/blog/critical-vulnerabilities-in-json-web-token-libraries/), which can be exploited by an attacker to generate trusted device cookies on their own, effectively by-passing two-factor authentication.
O3 Security · Impact-Aware SCA

Is GHSA-h6mp-mc7g-mg49 in your dependencies?

Find it across Packagist, including transitive dependencies.

scheb/two-factor-bundle bypass two-factor authentication…