ots has a negative expire override that can bypass its secret retention policyGHSA-h5fq-653g-gxrm
MEDIUMFix: Luzifer/ots@3511bd1GHSA-h5fq-653g-gxrm is a medium-severity (CVSS 5.3) vulnerability in github.com/Luzifer/ots. A fix is available for github.com/Luzifer/ots — see the affected versions and patch details below.
Real-World Exposure
github.com/Luzifer/otsReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.
Description
Summary
The /api/create endpoint accepted negative expire query values. For the memory storage backend, negative values were passed to secret creation as a negative duration and treated as no expiry, allowing callers to create secrets that persisted longer than intended.
Impact
Unauthenticated users could bypass configured retention expectations for secrets they create by sending POST /api/create?expire=-1.
This does not allow reading or modifying secrets created by other users. Secrets remain one-time-read and, in the normal web flow, client-side encrypted.
Affected versions
Versions up to and including v1.21.4 are affected.
Patched versions
Fixed in v1.21.5.
Workarounds
Disable expiry overrides via disableExpiryOverride: true until upgrading.
Credit
Reported by Chai Cheng Xun via email.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐹Go | github.com/Luzifer/ots | all versions | 1.21.5go get github.com/Luzifer/ots@v1.21.5 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/Luzifer/ots, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update github.com/Luzifer/ots to 1.21.5 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-h5fq-653g-gxrm is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is GHSA-h5fq-653g-gxrm in your dependencies?
Find it across Go, including transitive dependencies.