React Router has CSRF issue in Action/Server Action Request ProcessingGHSA-h5cw-625j-3rxh
MEDIUMGHSA-h5cw-625j-3rxh is a medium-severity (CVSS 6.5) CWE-346 vulnerability in react-router. A fix is available for react-router — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-h5cw-625j-3rxh.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
react-routernpm@remix-run/server-runtimenpmDescription
React Router is a router for React. In @remix-run/server-runtime version prior to 2.17.3. and react-router 7.0.0 through 7.11.0, React Router (or Remix v2) is vulnerable to CSRF attacks on document POST requests to UI routes when using server-side route action handlers in Framework Mode, or when using React Server Actions in the new unstable RSC modes. There is no impact if Declarative Mode (<BrowserRouter>) or Data Mode (createBrowserRouter/<RouterProvider>) is being used. This issue has been patched in @remix-run/server-runtime version 2.17.3 and react-router version 7.12.0.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | react-router | ≥ 7.0.0&&< 7.12.0 | 7.12.0npm install react-router@7.12.0 |
| 📦npm | @remix-run/server-runtime | all versions | 2.17.3npm install @remix-run/server-runtime@2.17.3 |
Affected Products
react-routershopifyremix-run\/reactshopifyDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for react-router, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update react-router to 7.12.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-h5cw-625j-3rxh is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base or stability.Source: Red Hat security advisory for GHSA-h5cw-625j-3rxh (CC BY 4.0)
Frequently Asked Questions
Is GHSA-h5cw-625j-3rxh in your dependencies?
Find it across npm, including transitive dependencies.