NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
HIGH severity

Next.js HTTP request deserialization can lead to DoS when using insecure React Server ComponentsGHSA-h25m-26qc-wcjf

HIGH

GHSA-h25m-26qc-wcjf is a high-severity (CVSS 7.5) remote code execution vulnerability in next. A fix is available for next — see the affected versions and patch details below.

Published
Updated
Affected
9 pkgs
Patched
9 / 9
Exploits
None indexed
Exploitation data as of Sep 10, 2026 · OSV.dev, FIRST.org (EPSS)

Real-World Exposure

9 pkgs affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

61Kother npm packages depend on this — each one inherits the vulnerability until it's patched upstream
nextnpm
91.0Mdownloads / week

Description

A vulnerability affects certain React Server Components packages for versions 19.0.x, 19.1.x, and 19.2.x and frameworks that use the affected packages, including Next.js 13.x, 14.x, 15.x, and 16.x using the App Router. The issue is tracked upstream as CVE-2026-23864.

A specially crafted HTTP request can be sent to any App Router Server Function endpoint that, when deserialized, may trigger excessive CPU usage, out-of-memory exceptions, or server crashes. This can result in denial of service in unpatched environments.

Affected Packages

9 total 9 fixed
EcosystemPackageVulnerable rangeFix
📦npmnext≥ 13.0.0&&< 15.0.815.0.8npm install next@15.0.8
📦npmnext≥ 15.1.1-canary.0&&< 15.1.1215.1.12npm install next@15.1.12
📦npmnext≥ 15.2.0-canary.0&&< 15.2.915.2.9npm install next@15.2.9
📦npmnext≥ 15.3.0-canary.0&&< 15.3.915.3.9npm install next@15.3.9
📦npmnext≥ 15.4.0-canary.0&&< 15.4.1115.4.11npm install next@15.4.11
📦npmnext≥ 15.5.1-canary.0&&< 15.5.1015.5.10npm install next@15.5.10

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for next, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update next to 15.0.8 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-h25m-26qc-wcjf is resolved across your whole dependency graph.

  3. Workarounds

    Do not deserialise data from untrusted sources: where the format allows it, restrict deserialisation to an explicit allowlist of expected types, and prefer a data-only format (JSON, Protobuf) over one that can reconstruct arbitrary objects until you can upgrade.

Frequently Asked Questions

A vulnerability affects certain React Server Components packages for versions 19.0.x, 19.1.x, and 19.2.x and frameworks that use the affected packages, including Next.js 13.x, 14.x, 15.x, and 16.x using the App Router. The issue is tracked upstream as [CVE-2026-23864](https://github.com/facebook/react/security/advisories/GHSA-83fc-fqcc-2hmg). A specially crafted HTTP request can be sent to any App Router Server Function endpoint that, when deserialized, may trigger excessive CPU usage, out-of-memory exceptions, or server crashes. This can result in denial of service in unpatched environments.
O3 Security · Impact-Aware SCA

Is GHSA-h25m-26qc-wcjf in your dependencies?

Find it across npm, including transitive dependencies.

Next.js HTTP request deserialization can lead to DoS…