Electron's Content-Secrity-Policy disabling eval not applied consistently in renderers with sandbox disabledGHSA-gxh7-wv9q-fwfr
HIGHFix: electron/electron#36667GHSA-gxh7-wv9q-fwfr is a high-severity (CVSS 7.5) CWE-670 vulnerability in electron. A fix is available for electron — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- A successful exploit gives an attacker total control of the affected component, not partial access.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-gxh7-wv9q-fwfr.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
electronnpmDescription
Impact
A Content-Security-Policy that disables eval, specifically setting a script-src directive and not providing unsafe-eval in that directive, is not respected in renderers that have sandbox and contextIsolation disabled. i.e. sandbox: false and contextIsolation: false in the webPreferences object.
This resulted in incorrectly allowing usage of methods like eval() and new Function, which can result in an expanded attack surface.
Patches
This issue only ever affected the 22 and 23 major versions of Electron and has been fixed in the latest versions of those release lines. Specifically, these versions contain the fixes:
- 22.0.1
- 23.0.0-alpha.2
We recommend all apps upgrade to the latest stable version of Electron, especially if they use sandbox: false or contextIsolation: false.
Workarounds
If upgrading isn't possible, this issue can be addressed without upgrading by enabling at least one of sandbox: true or contextIsolation: true on all renderers.
const mainWindow = new BrowserWindow({
webPreferences: {
sandbox: true,
}
});
For more information
If you have any questions or comments about this advisory, email us at [email protected].
Credit
Thanks to user @andreasdj for reporting this issue.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | electron | ≥ 22.0.0-beta.1&&< 22.0.1 | 22.0.1npm install electron@22.0.1 |
| 📦npm | electron | ≥ 23.0.0-alpha.1&&< 23.0.0-alpha.2 | 23.0.0-alpha.2npm install electron@23.0.0-alpha.2 |
Affected Products
electronelectronjsDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for electron, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update electron to 22.0.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-gxh7-wv9q-fwfr is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is GHSA-gxh7-wv9q-fwfr in your dependencies?
Find it across npm, including transitive dependencies.