Jetty Utility Servlets ConcatServlet Double Decoding Information Disclosure VulnerabilityGHSA-gwcr-j4wh-j3cq
MEDIUMGHSA-gwcr-j4wh-j3cq is a medium-severity (CVSS 5.3) Information Exposure vulnerability in org.eclipse.jetty:jetty-servlets. EPSS puts its 30-day exploitation probability at 78.5% (100th percentile). A fix is available for org.eclipse.jetty:jetty-servlets — see the affected versions and patch details below.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.eclipse.jetty:jetty-servlets☕org.eclipse.jetty:jetty-servlets☕org.eclipse.jetty:jetty-servletsReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Requests to the ConcatServlet and WelcomeFilter are able to access protected resources within the WEB-INF directory. For example a request to the ConcatServlet with a URI of /concat?/%2557EB-INF/web.xml can retrieve the web.xml file. This can reveal sensitive information regarding the implementation of a web application.
This occurs because both ConcatServlet and WelcomeFilter decode the supplied path to verify it is not within the WEB-INF or META-INF directories. It then uses this decoded path to call RequestDispatcher which will also do decoding of the path. This double decoding allows paths with a doubly encoded WEB-INF to bypass this security check.
Impact
This affects all versions of ConcatServlet and WelcomeFilter in versions before 9.4.41, 10.0.3 and 11.0.3.
Workarounds
If you cannot update to the latest version of Jetty, you can instead deploy your own version of the ConcatServlet and/or the WelcomeFilter by using the code from the latest version of Jetty.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.eclipse.jetty:jetty-servlets | all versions | 9.4.41org.eclipse.jetty:jetty-servlets:9.4.41 |
| ☕Maven | org.eclipse.jetty:jetty-servlets | ≥ 10.0.0&&< 10.0.3 | 10.0.3org.eclipse.jetty:jetty-servlets:10.0.3 |
| ☕Maven | org.eclipse.jetty:jetty-servlets | ≥ 11.0.0&&< 11.0.3 | 11.0.3org.eclipse.jetty:jetty-servlets:11.0.3 |
Affected Products
debian linuxdebianjettyeclipseactive iq unified managernetapphcinetappmanagement services for element softwarenetappsnap creator frameworknetappDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.eclipse.jetty:jetty-servlets, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.eclipse.jetty:jetty-servlets to 9.4.41 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-gwcr-j4wh-j3cq is resolved across your whole dependency graph.
Workarounds
Assume what was exposed is already known: rotate any credential, token or key that the affected component could return, restrict the endpoint to callers that genuinely need it, and strip sensitive fields from responses and error output at the boundary rather than relying on the client not to read them.
How to detect GHSA-gwcr-j4wh-j3cq
A community-maintained Nuclei template exists for this CVE. You can scan for it directly:
nuclei -id ghsa-gwcr-j4wh-j3cq -u https://target- Template
- Eclipse Jetty ConcatServlet - Information Disclosure
- Severity
- medium
- Impact
- An attacker can exploit this vulnerability to access sensitive information, potentially leading to further attacks or unauthorized access.
- Remediation
- Upgrade to Eclipse Jetty version 9.4.40 or later to mitigate this vulnerability.
Template by ProjectDiscovery nuclei-templates (pikpikcu), MIT licensed. View the full template. Scan only systems you are authorised to test.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
In OpenShift Container Platform (OCP), the hive/presto/hadoop components that comprise the OCP metering stack, ship the vulnerable version of jetty. Since the release of OCP 4.6, the metering product has been deprecated [1], hence the affected components are marked as wontfix. This may be fixed in the future. [1]…
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat AMQ 7.9.0 | jetty-server | RHSA-2021:3700 |
| Red Hat AMQ Streams 1.8.0 | jetty-server | RHSA-2021:3225 |
| Red Hat Fuse 7.10 | jetty | RHSA-2021:5134 |
| Red Hat Integration Camel Quarkus 2 | see advisory | RHSA-2021:4767 |
| Red Hat OpenShift Container Platform 4.9 | jenkins-0:2.289.3.1630554997-1.el8 | RHSA-2021:3758 |
| RHINT Camel-K 1.8.1 | jetty | RHSA-2022:7257 |
Frequently Asked Questions
Is GHSA-gwcr-j4wh-j3cq in your dependencies?
Find it across Maven, including transitive dependencies.