TYPO3 HTML Sanitizer Bypasses Cross-Site Scripting ProtectionGHSA-gqqf-g5r7-84vf
MEDIUMFix: TYPO3/typo3@d4f2605GHSA-gqqf-g5r7-84vf is a medium-severity (CVSS 6.1) vulnerability in typo3/cms-core. A fix is available for typo3/cms-core — see the affected versions and patch details below.
Real-World Exposure
typo3/cms-core🐘typo3/cms-core🐘typo3/cms-core🐘typo3/cms-core🐘typo3/cms-coreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Meta
- CVSS:
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N/E:F/RL:O/RC:C(5.7)
Problem
Due to a parsing issue in upstream package masterminds/html5, malicious markup used in a sequence with special HTML comments cannot be filtered and sanitized. This allows to by-pass the cross-site scripting mechanism of typo3/html-sanitizer.
Solution
Update to TYPO3 version 7.6.58 ELTS, 8.7.48 ELTS, 9.5.37 ELTS, 10.4.32 or 11.5.16 that fix the problem described above.
Credits
Thanks to David Klein who reported this issue, and to TYPO3 security team member Oliver Hader who fixed the issue.
References
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | typo3/cms-core | ≥ 7.0.0&&< 7.6.58 | 7.6.58composer require typo3/cms-core:^7.6.58 |
| 🐘Packagist | typo3/cms-core | ≥ 8.0.0&&< 8.7.48 | 8.7.48composer require typo3/cms-core:^8.7.48 |
| 🐘Packagist | typo3/cms-core | ≥ 9.0.0&&< 9.5.37 | 9.5.37composer require typo3/cms-core:^9.5.37 |
| 🐘Packagist | typo3/cms-core | ≥ 10.0.0&&< 10.4.32 | 10.4.32composer require typo3/cms-core:^10.4.32 |
| 🐘Packagist | typo3/cms-core | ≥ 11.0.0&&< 11.5.16 | 11.5.16composer require typo3/cms-core:^11.5.16 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for typo3/cms-core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update typo3/cms-core to 7.6.58 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-gqqf-g5r7-84vf is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is GHSA-gqqf-g5r7-84vf in your dependencies?
Find it across Packagist, including transitive dependencies.