NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
.NET NuGet
Not in CISA KEV

Remote code execution vulnerability in dependency System.Drawing.CommonGHSA-gpv5-rp6w-58r8

GHSA-gpv5-rp6w-58r8 is a remote code execution vulnerability in Akka. A fix is available for Akka — see the affected versions and patch details below.

Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Dec 4, 2024 · OSV.dev, FIRST.org (EPSS)

Real-World Exposure

2 pkgs affected
.NETAkka.NETAkka

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects NuGet packages — download data is not available via public APIs for these ecosystems.

Description

Impact

The core Akka module depended on an old System.Configuration.ConfigurationManager version 4.7.0 which transitively depends on System.Common.Drawing v4.7.0. The System.Common.Drawing v4.7.0 is affected by a remote code execution vulnerability https://github.com/advisories/GHSA-ghhp-997w-qr28.

The real-world impact of this should be low, but users should be advised to upgrade to later versions of Akka.NET.

Patches

Has the problem been patched? What versions should users upgrade to?

This issue is resolved in Akka.NET v1.4.46 and Akka.NET v1.5.0-alpha3.

Workarounds

Is there a way for users to fix or remediate the vulnerability without upgrading?

You might be able to explicitly reference System.Configuration.ConfigurationManager's NuGet package and upgrade to 6.0.1 or later without upgrading Akka.NET, but it's probably best to upgrade Akka.NET itself.

References

Are there any links users can visit to find out more?

Original issue: https://github.com/akkadotnet/akka.net/issues/6226 MSFT advisory: https://github.com/advisories/GHSA-ghhp-997w-qr28

For more information

If you have any questions or comments about this advisory:

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
.NETNuGetAkkaall versions1.4.46dotnet add package Akka --version 1.4.46
.NETNuGetAkka≥ 1.5.0-alpha1&&< 1.5.0-alpha31.5.0-alpha3dotnet add package Akka --version 1.5.0-alpha3

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for Akka, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update Akka to 1.4.46 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-gpv5-rp6w-58r8 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

### Impact The core Akka module depended on an old System.Configuration.ConfigurationManager version 4.7.0 which transitively depends on System.Common.Drawing v4.7.0. The System.Common.Drawing v4.7.0 is affected by a remote code execution vulnerability https://github.com/advisories/GHSA-ghhp-997w-qr28. The real-world impact of this should be low, but users should be advised to upgrade to later versions of Akka.NET. ### Patches _Has the problem been patched? What versions should users upgrade to?_ This issue is resolved in Akka.NET v1.4.46 and Akka.NET v1.5.0-alpha3. ### Workarounds _Is th
O3 Security · Impact-Aware SCA

Is GHSA-gpv5-rp6w-58r8 in your dependencies?

Find it across NuGet, including transitive dependencies.

Remote code execution vulnerability in dependency…