OpenClaw: LINE group allowlist scope mismatch with DM pairing-store entriesGHSA-gp3q-wpq4-5c5h
HIGHFix: openclaw/openclaw@892a9c2GHSA-gp3q-wpq4-5c5h is a high-severity (CVSS 7.1) vulnerability in openclaw. A fix is available for openclaw — see the affected versions and patch details below.
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
openclawnpmDescription
Summary
In specific LINE configurations, sender IDs approved through DM pairing could also satisfy group allowlist checks when operators expected group sender access to be scoped only to explicit group allowlists.
Affected Packages / Versions
- Package:
openclaw(npm) - Latest published version at triage/update time:
2026.2.25 - Affected:
<= 2026.2.25 - Patched:
>= 2026.2.26(planned next release)
Impact
This is a group-authorization scope mismatch. DM pairing-store entries could influence group sender authorization in allowlist mode.
Technical Details
Root cause: group allowlist composition inherited pairing-store entries intended for DM approvals. Under default DM pairing policy, a DM-paired sender could match group allowlist checks.
Fixes on main:
- isolate group allowlist composition from pairing-store entries
- centralize shared DM/group allowlist composition to preserve DM-only pairing behavior
- add regression coverage for LINE and Mattermost policy paths
Fix Commit(s)
8bdda7a651c21e98faccdbbd73081e79cffe8be0892a9c24b0f6118729ab5b5f5499b1a7e792dd15(follow-up refactor hardening)
Release Process Note
patched_versions is pre-set to >= 2026.2.26 so once npm 2026.2.26 is published, this advisory can be published directly without additional version-field edits.
Thanks @tdjackey for reporting.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | openclaw | all versions | 2026.2.26npm install openclaw@2026.2.26 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for openclaw, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update openclaw to 2026.2.26 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-gp3q-wpq4-5c5h is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is GHSA-gp3q-wpq4-5c5h in your dependencies?
Find it across npm, including transitive dependencies.