Mimekit has vulnerable dependency that can lead to denial of serviceGHSA-gmc6-fwg3-75m5
HIGHFix: jstedfast/MimeKit@aef4edaGHSA-gmc6-fwg3-75m5 is a high-severity (CVSS 7.5) vulnerability in MimeKit. A fix is available for MimeKit — see the affected versions and patch details below.
Real-World Exposure
MimeKitReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects NuGet packages — download data is not available via public APIs for these ecosystems.
Description
Summary
Denial of service vulnerability.
Details
See: https://github.com/advisories/GHSA-447r-wph3-92pm and https://github.com/dotnet/announcements/issues/312
PoC
Update System.Security.Cryptography.Pkcs to 8.0.1 so that the transitive dependency with the issue gets updated
Impact
Denial of service vulnerability. Affects MimeKit (>= v3.0.0 and <= v4.7.0) when used to decrypt or verify incoming S/MIME messages as well as importing 3rd-party X.509 certificates for use with encrypting outgoing S/MIME messages.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| .NETNuGet | MimeKit | ≥ 3.0.0&&< 4.7.1 | 4.7.1dotnet add package MimeKit --version 4.7.1 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for MimeKit, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update MimeKit to 4.7.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-gmc6-fwg3-75m5 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Frequently Asked Questions
Is GHSA-gmc6-fwg3-75m5 in your dependencies?
Find it across NuGet, including transitive dependencies.