NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

Bolt Cross-site Scripting (XSS) via text input click preview buttonGHSA-gjx6-58xh-p7pw

MEDIUM

GHSA-gjx6-58xh-p7pw is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in bolt/bolt. 3 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for bolt/bolt — see the affected versions and patch details below.

Also known asCVE-2018-19933
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
3 known
Exploitation data as of Nov 7, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
3.5%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs89th percentile — riskier than 89% of all scored CVEsHighest risk
1.74%2.48%3.23%3.97%2.2%3.5%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘bolt/bolt

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Bolt CMS <3.6.2 allows XSS via text input click preview button as demonstrated by the Title field of a Configured and New Entry.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistbolt/boltall versions3.6.2composer require bolt/bolt:^3.6.2

Affected Products

1 product · 1 configurations
Application
bolt cmsbolt
< 3.6.2
range
Exploits & PoCs
3

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

EDB-46014webappsphp

Bolt CMS < 3.6.2 - Cross-Site Scripting

by Raif Berkay Dincel · Dec 19, 2018

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for bolt/bolt, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update bolt/bolt to 3.6.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-gjx6-58xh-p7pw is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Bolt CMS <3.6.2 allows XSS via text input click preview button as demonstrated by the Title field of a Configured and New Entry.
O3 Security · Impact-Aware SCA

Is GHSA-gjx6-58xh-p7pw in your dependencies?

Find it across Packagist, including transitive dependencies.

Bolt Cross-site Scripting (XSS) via text input click preview…