XWiki Platform Security Parent POM vulnerable to overwriting of security rules of a page with a final page having the same referenceGHSA-gg53-wf5x-r3r6
HIGHGHSA-gg53-wf5x-r3r6 is a high-severity (CVSS 7.1) CWE-285 vulnerability in org.xwiki.platform:xwiki-platform-security. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for org.xwiki.platform:xwiki-platform-security — see the affected versions and patch details below.
Exploitation Status
Proof-of-concept exploit code exists
- CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
Exploitation and automatability from CISA’s SSVC triage for GHSA-gg53-wf5x-r3r6.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.xwiki.platform:xwiki-platform-security☕org.xwiki.platform:xwiki-platform-security☕org.xwiki.platform:xwiki-platform-securityReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Impact
A bug in the security cache is storing rules associated to document Page1.Page2 and space Page1.Page2 in the same cache entry.
That means that it's possible to overwrite the rights of a space or a document by creating the page of the space with the same name and checking the right of the new one first so that they end up in the security cache and are used for the other too.
Patches
The problem has been patched in XWiki 12.10.11, 13.10.1, 13.4.6.
Workarounds
No workaround other than patching.
References
https://jira.xwiki.org/browse/XWIKI-14075 https://jira.xwiki.org/browse/XWIKI-18983
For more information
If you have any questions or comments about this advisory:
- Open an issue in Jira XWiki.org
- Email us at Security Mailing List
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.xwiki.platform:xwiki-platform-security | ≥ 5.0&&< 12.10.11 | 12.10.11org.xwiki.platform:xwiki-platform-security:12.10.11 |
| ☕Maven | org.xwiki.platform:xwiki-platform-security | ≥ 13.0&&< 13.4.6 | 13.4.6org.xwiki.platform:xwiki-platform-security:13.4.6 |
| ☕Maven | org.xwiki.platform:xwiki-platform-security | ≥ 13.10&&< 13.10.1 | 13.10.1org.xwiki.platform:xwiki-platform-security:13.10.1 |
Affected Products
xwikixwikiResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.xwiki.platform:xwiki-platform-security, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.xwiki.platform:xwiki-platform-security to 12.10.11 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-gg53-wf5x-r3r6 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Frequently Asked Questions
Is GHSA-gg53-wf5x-r3r6 in your dependencies?
Find it across Maven, including transitive dependencies.