Juju affected by timing ownership claim attack on new external back-end secretsGHSA-gfgr-6hrj-85ww
MEDIUMGHSA-gfgr-6hrj-85ww is a medium-severity (CVSS 5.3) CWE-708 vulnerability in github.com/juju/juju. A fix is available for github.com/juju/juju — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-gfgr-6hrj-85ww.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
github.com/juju/jujuReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.
Description
A race condition in the secrets management subsystem of Juju versions 3.0.0 through 3.6.18 allows an authenticated unit agent to claim ownership of a newly initialized secret. Between generating a Juju Secret ID and creating the secret's first revision, an attacker authenticated as another unit agent can claim ownership of a known secret. This leads to the attacking unit being able to read the content of the initial secret revision.
Impact
Between generating a Secret ID and creating the secret's first revision, an attacker authenticated as another unit agent can claim ownership of a known secret. This leads to the attacking unit being able to read the content of the initial secret revision.
Patches
3.6.19
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐹Go | github.com/juju/juju | ≥ 3.0.0&&< 3.6.19 | 3.6.19go get github.com/juju/juju@v3.6.19 |
Affected Products
jujucanonicalDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/juju/juju, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update github.com/juju/juju to 3.6.19 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-gfgr-6hrj-85ww is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is GHSA-gfgr-6hrj-85ww in your dependencies?
Find it across Go, including transitive dependencies.