NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
MEDIUM severity

Requests has Insecure Temp File Reuse in its extract_zipped_paths() utility functionGHSA-gc5v-m9x4-r6x2

MEDIUMFix: psf/requests@66d21cb

GHSA-gc5v-m9x4-r6x2 is a medium-severity (CVSS 4.4) CWE-377 vulnerability in requests. A fix is available for requests — see the affected versions and patch details below.

Also known asCVE-2026-25645PYSEC-2026-2275
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for GHSA-gc5v-m9x4-r6x2.

EPSS Exploitation Probability

via FIRST.org ↗
0.2%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs9th percentile — riskier than 9% of all scored CVEsHighest risk
0.00%0.23%0.46%0.69%0.0%0.2%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍requests

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

Impact

The requests.utils.extract_zipped_paths() utility function uses a predictable filename when extracting files from zip archives into the system temporary directory. If the target file already exists, it is reused without validation. A local attacker with write access to the temp directory could pre-create a malicious file that would be loaded in place of the legitimate one.

Affected usages

Standard usage of the Requests library is not affected by this vulnerability. Only applications that call extract_zipped_paths() directly are impacted.

Remediation

Upgrade to at least Requests 2.33.0, where the library now extracts files to a non-deterministic location.

If developers are unable to upgrade, they can set TMPDIR in their environment to a directory with restricted write access.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIrequestsall versions2.33.0pip install --upgrade 'requests==2.33.0'

Affected Products

1 product · 1 configurations
Application
requestspython
< 2.33.0
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for requests, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update requests to 2.33.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-gc5v-m9x4-r6x2 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate
Workaround published by Red Hat
Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base or stability.
Source: Red Hat security advisory for GHSA-gc5v-m9x4-r6x2 (CC BY 4.0)
ProductFixed inAdvisory
Red Hat AI Inference Server 3.4rhaii/model-opt-cuda-rhel9:1787151832RHSA-2026:57383
Red Hat Enterprise Linux AI 3.4rhelai3/disk-image-cuda-rhel9:1787310717RHSA-2026:59144
Red Hat Enterprise Linux AI 3.4rhelai3/bootc-aws-cuda-rhel9:1787253912RHSA-2026:59151
Red Hat Openshift Data Foundation 4.18odf4/cephcsi-rhel9:1786705347RHSA-2026:56431

Frequently Asked Questions

### Impact The `requests.utils.extract_zipped_paths()` utility function uses a predictable filename when extracting files from zip archives into the system temporary directory. If the target file already exists, it is reused without validation. A local attacker with write access to the temp directory could pre-create a malicious file that would be loaded in place of the legitimate one. ### Affected usages **Standard usage of the Requests library is not affected by this vulnerability.** Only applications that call `extract_zipped_paths()` directly are impacted. ### Remediation Upgrade to at l
O3 Security · Impact-Aware SCA

Is GHSA-gc5v-m9x4-r6x2 in your dependencies?

Find it across PyPI, including transitive dependencies.

Requests has Insecure Temp File Reuse in its…