GHSA-g954-5hwp-pp24 is a high-severity (CVSS 7.5) CWE-1321 vulnerability in protobufjs. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for protobufjs — see the affected versions and patch details below.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
protobufjsnpmDescription
The package protobufjs is vulnerable to Prototype Pollution, which can allow an attacker to add/modify properties of the Object.prototype. Versions after and including 6.10.0 until 6.10.3 and after and including 6.11.0 until 6.11.3 are vulnerable.
This vulnerability can occur in multiple ways:
- by providing untrusted user input to util.setProperty or to ReflectionObject.setParsedOption functions
- by parsing/loading .proto files
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | protobufjs | ≥ 6.11.0&&< 6.11.3 | 6.11.3npm install protobufjs@6.11.3 |
| 📦npm | protobufjs | ≥ 6.10.0&&< 6.10.3 | 6.10.3npm install protobufjs@6.10.3 |
Affected Products
protobufjsprotobufjs_projectResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for protobufjs, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update protobufjs to 6.11.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-g954-5hwp-pp24 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is GHSA-g954-5hwp-pp24 in your dependencies?
Find it across npm, including transitive dependencies.