NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐹
🐹 Go
Not in CISA KEV
HIGH severity

Talos Linux ships runc vulnerable to the escape to the host attackGHSA-g5p6-327m-3fxx

HIGH

GHSA-g5p6-327m-3fxx is a high-severity (CVSS 8.6) vulnerability in github.com/siderolabs/talos. A fix is available for github.com/siderolabs/talos — see the affected versions and patch details below.

Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Feb 2, 2024 · OSV.dev, FIRST.org (EPSS)

Real-World Exposure

2 pkgs affected
🐹github.com/siderolabs/talos🐹github.com/siderolabs/talos

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.

Description

Impact

Snyk has discovered a vulnerability in all versions of runc <=1.1.11, as used by the Docker engine, along with other containerization technologies such as Kubernetes. Exploitation of this issue can result in container escape to the underlying host OS, either through executing a malicious image or building an image using a malicious Dockerfile or upstream image (i.e., when using FROM). This issue has been assigned the CVE-2024-21626.

Patches

runc runtime was updated to 1.1.12 in Talos v1.5.6 and v1.6.4.

Workarounds

Inspect the workloads running on the cluster to make sure they are not trying to exploit the vulnerability.

References

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
🐹Gogithub.com/siderolabs/talos≥ 1.6.0&&< 1.6.41.6.4go get github.com/siderolabs/talos@v1.6.4
🐹Gogithub.com/siderolabs/talosall versions1.5.6go get github.com/siderolabs/talos@v1.5.6

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/siderolabs/talos, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update github.com/siderolabs/talos to 1.6.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-g5p6-327m-3fxx is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

### Impact Snyk has discovered a vulnerability in all versions of runc <=1.1.11, as used by the Docker engine, along with other containerization technologies such as Kubernetes. Exploitation of this issue can result in container escape to the underlying host OS, either through executing a malicious image or building an image using a malicious Dockerfile or upstream image (i.e., when using FROM). This issue has been assigned the CVE-2024-21626. ### Patches `runc` runtime was updated to 1.1.12 in Talos v1.5.6 and v1.6.4. ### Workarounds Inspect the workloads running on the cluster to make s
O3 Security · Impact-Aware SCA

Is GHSA-g5p6-327m-3fxx in your dependencies?

Find it across Go, including transitive dependencies.

Talos Linux ships runc vulnerable to the escape to the…