next-mdx-remote affected by arbitrary code execution in React server-side rendering of untrusted MDX contentGHSA-g4xw-jxrg-5f6m
HIGHFix: hashicorp/next-mdx-remote@4d527fdGHSA-g4xw-jxrg-5f6m is a high-severity (CVSS 8.8) Code Injection vulnerability in next-mdx-remote. A fix is available for next-mdx-remote — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- A successful exploit gives an attacker total control of the affected component, not partial access.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-g4xw-jxrg-5f6m.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
next-mdx-remotenpmDescription
The serialize function used to compile MDX in next-mdx-remote is vulnerable to arbitrary code execution due to insufficient sanitization of MDX content. This vulnerability, CVE-2026-0969, is fixed in next-mdx-remote 6.0.0.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | next-mdx-remote | ≥ 4.3.0&&< 6.0.0 | 6.0.0npm install next-mdx-remote@6.0.0 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for next-mdx-remote, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update next-mdx-remote to 6.0.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-g4xw-jxrg-5f6m is resolved across your whole dependency graph.
Workarounds
Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.
Frequently Asked Questions
Is GHSA-g4xw-jxrg-5f6m in your dependencies?
Find it across npm, including transitive dependencies.