Defense in Depth update for NuGet ClientGHSA-g4vj-cjjj-v7hg
GHSA-g4vj-cjjj-v7hg is a security vulnerability in NuGet.Packaging. A fix is available for NuGet.Packaging — see the affected versions and patch details below.
Real-World Exposure
NuGet.Packaging.NETNuGet.Packaging.NETNuGet.Packaging.NETNuGet.Packaging.NETNuGet.Packaging.NETNuGet.Packaging.NETNuGet.Packaging.NETNuGet.Packaging+16 moreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects NuGet packages — download data is not available via public APIs for these ecosystems.
Description
Impact
This update adds validation of the package ID and version during package download, in addition to the existing package signature validation.
Patches
NuGet
The following NuGet.exe, NuGet.CommandLine, NuGet.Packaging, and NuGet.Protocol versions have been patched:
| Affected versions | Patched version |
|---|---|
| >= 4.9.0, <= 4.9.6 | 4.9.7 |
| >= 5.11.0, <= 5.11.6 | 5.11.7 |
| >= 6.8.0, <= 6.8.1 | 6.8.2 |
| >= 6.11.0, <= 6.11.1 | 6.11.2 |
| >= 6.12.0, <= 6.12.4 | 6.12.5 |
| >= 6.14.0, <= 6.14.2 | 6.14.3 |
| >= 7.0.0, <= 7.0.2 | 7.0.3 |
| 7.3.0 | 7.3.1 |
.NET SDK
- .NET 8.0.126 SDK
- .NET 8.0.420 SDK
- .NET 9.0.116 SDK
- .NET 9.0.313 SDK
- .NET 10.0.106 SDK
- .NET 10.0.202 SDK
Workarounds
N/A
References
https://github.com/NuGet/NuGetGallery/security/advisories/GHSA-9r3h-v4hx-rhfr
Credit
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| .NETNuGet | NuGet.Packaging | ≥ 4.9.0&&< 4.9.7 | 4.9.7dotnet add package NuGet.Packaging --version 4.9.7 |
| .NETNuGet | NuGet.Packaging | ≥ 5.11.0&&< 5.11.7 | 5.11.7dotnet add package NuGet.Packaging --version 5.11.7 |
| .NETNuGet | NuGet.Packaging | ≥ 6.8.0&&< 6.8.2 | 6.8.2dotnet add package NuGet.Packaging --version 6.8.2 |
| .NETNuGet | NuGet.Packaging | ≥ 6.11.0&&< 6.11.2 | 6.11.2dotnet add package NuGet.Packaging --version 6.11.2 |
| .NETNuGet | NuGet.Packaging | ≥ 6.12.0&&< 6.12.5 | 6.12.5dotnet add package NuGet.Packaging --version 6.12.5 |
| .NETNuGet | NuGet.Packaging | ≥ 6.14.0&&< 6.14.3 | 6.14.3dotnet add package NuGet.Packaging --version 6.14.3 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for NuGet.Packaging, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update NuGet.Packaging to 4.9.7 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-g4vj-cjjj-v7hg is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is GHSA-g4vj-cjjj-v7hg in your dependencies?
Find it across NuGet, including transitive dependencies.