NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐹
🐹 Go
Not in CISA KEV
HIGH severity

ipld/go-codec-dagpb panics when processing certain blocksGHSA-g3vv-g2j5-45f2

HIGHFix: ipld/go-codec-dagpb@a17ace3

GHSA-g3vv-g2j5-45f2 is a high-severity (CVSS 7.5) Buffer Overflow vulnerability in github.com/ipld/go-codec-dagpb. A fix is available for github.com/ipld/go-codec-dagpb — see the affected versions and patch details below.

Also known asCVE-2022-2584GHSA-967g-cjx4-h7j6GO-2022-0422
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for GHSA-g3vv-g2j5-45f2.

EPSS Exploitation Probability

via FIRST.org ↗
0.8%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs56th percentile — riskier than 56% of all scored CVEsHighest risk
0.00%0.42%0.85%1.27%0.5%0.8%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐹github.com/ipld/go-codec-dagpb

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.

Description

Impact

Decoding certain blocks using the go-ipld-prime version of the dag-pb codec (go-codec-dagpb) can cause a panic. The panic comes from an assumption that the reported link length is accurate, but if the block ends before that reported length then it’s a buffer overread.

Patches

The issue is fixed in v1.3.1 and above.

Consumers can discover the versions of go-codec-dagpb in a module's dependency graph using the following command in the module root:

go mod graph | grep go-codec-dagpb

Workarounds

You can work around this issue without upgrading by recovering panics higher in the call stack of the goroutine that calls the defective code.

For more information

If you have any questions or comments about this advisory:

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐹Gogithub.com/ipld/go-codec-dagpball versions1.3.1go get github.com/ipld/go-codec-dagpb@v1.3.1

Affected Products

1 product · 1 configurations
Application
go-codec-dagpbprotocol
< 1.3.1
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/ipld/go-codec-dagpb, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update github.com/ipld/go-codec-dagpb to 1.3.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-g3vv-g2j5-45f2 is resolved across your whole dependency graph.

  3. Workarounds

    Stop feeding it untrusted input: reject or quarantine files and payloads from unverified sources until you can upgrade, restrict accepted formats to the ones you actually need, and run the parsing or decoding step in a least-privileged sandbox or short-lived worker so a crash or corrupted read cannot reach the rest of the process.

Frequently Asked Questions

### Impact Decoding certain blocks using the go-ipld-prime version of the dag-pb codec (go-codec-dagpb) can cause a panic. The panic comes from an assumption that the reported link length is accurate, but if the block ends before that reported length then it’s a buffer overread. ### Patches The issue is fixed in v1.3.1 and above. Consumers can discover the versions of `go-codec-dagpb` in a module's dependency graph using the following command in the module root: ```go mod graph | grep go-codec-dagpb``` ### Workarounds You can work around this issue without upgrading by recovering panics
O3 Security · Impact-Aware SCA

Is GHSA-g3vv-g2j5-45f2 in your dependencies?

Find it across Go, including transitive dependencies.

GHSA-g3vv-g2j5-45f2: go-codec-dagpb — Fixed in 1.3.1