NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

omeka/omeka-s Improper Input Validation vulnerabilityGHSA-fxc5-pr68-2px3

MEDIUMFix: omeka/omeka-s@8b72619

GHSA-fxc5-pr68-2px3 is a medium-severity (CVSS 5.2) CWE-74 vulnerability in omeka/omeka-s. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for omeka/omeka-s — see the affected versions and patch details below.

Also known asCVE-2023-4157
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

Proof-of-concept exploit code exists

  • CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.

Exploitation and automatability from CISA’s SSVC triage for GHSA-fxc5-pr68-2px3.

EPSS Exploitation Probability

via FIRST.org ↗
0.5%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs44th percentile — riskier than 44% of all scored CVEsHighest risk
0.00%0.34%0.68%1.01%0.1%0.5%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘omeka/omeka-s

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

CWE-74 Improper Neutralization of Special Elements in Output Used by a Downstream Component ('Injection') in GitHub repository omeka/omeka-s prior to version 4.0.3.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistomeka/omeka-sall versions4.0.3composer require omeka/omeka-s:^4.0.3

Affected Products

1 product · 1 configurations
Application
omeka someka
< 4.0.3
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for omeka/omeka-s, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update omeka/omeka-s to 4.0.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-fxc5-pr68-2px3 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

Improper Input Validation in GitHub repository omeka/omeka-s prior to 4.0.3.
O3 Security · Impact-Aware SCA

Is GHSA-fxc5-pr68-2px3 in your dependencies?

Find it across Packagist, including transitive dependencies.

omeka/omeka-s Improper Input Validation vulnerability