NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
CRITICAL severity

SQL injection in typeORMGHSA-fx4w-v43j-vc45

CRITICAL

GHSA-fx4w-v43j-vc45 is a critical-severity (CVSS 9.8) SQL Injection vulnerability in typeorm. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for typeorm — see the affected versions and patch details below.

Also known asCVE-2022-33171
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
2 known
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

Proof-of-concept exploit code exists

  • CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.

Exploitation and automatability from CISA’s SSVC triage for GHSA-fx4w-v43j-vc45.

EPSS Exploitation Probability

via FIRST.org ↗
21.4%probability of exploitation in next 30 days
Moderate Risk0.00%
Lower risk than most CVEs98th percentile — riskier than 98% of all scored CVEsHighest risk
0.00%8.95%17.9%26.9%3.2%21.4%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

5Kother npm packages depend on this — each one inherits the vulnerability until it's patched upstream
typeormnpm
6.7Mdownloads / week

Description

The findOne function in TypeORM before 0.3.0 can either be supplied with a string or a FindOneOptions object. When input to the function is a user-controlled parsed JSON object, supplying a crafted FindOneOptions instead of an id string leads to SQL injection. NOTE: the vendor's position is that the user's application is responsible for input validation.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmtypeormall versions0.3.0npm install typeorm@0.3.0

Affected Products

1 product · 1 configurations
Application
typeormtypeorm
< 0.3.0
range
Exploits & PoCs
2

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for typeorm, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update typeorm to 0.3.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-fx4w-v43j-vc45 is resolved across your whole dependency graph.

  3. Workarounds

    Until you can upgrade, make sure every query built from user input uses parameterised statements or a prepared-statement API rather than string concatenation, and reduce the database account's privileges so an injected query cannot read or alter data beyond what the feature needs.

Frequently Asked Questions

The findOne function in TypeORM before 0.3.0 can either be supplied with a string or a FindOneOptions object. When input to the function is a user-controlled parsed JSON object, supplying a crafted FindOneOptions instead of an id string leads to SQL injection. NOTE: the vendor's position is that the user's application is responsible for input validation.
O3 Security · Impact-Aware SCA

Is GHSA-fx4w-v43j-vc45 in your dependencies?

Find it across npm, including transitive dependencies.

SQL injection in typeORM (Critical 9.8)