NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
HIGH severity

Silverstripe CSRF Protection Bypass via GraphQLGHSA-fx37-56v6-85q6

HIGHFix: silverstripe/silverstripe-graphql@3c1dd6b

GHSA-fx37-56v6-85q6 is a high-severity (CVSS 8.8) Cross-Site Request Forgery (CSRF) vulnerability in silverstripe/graphql. A fix is available for silverstripe/graphql — see the affected versions and patch details below.

Also known asCVE-2019-12437
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 7, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.7%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs55th percentile — riskier than 55% of all scored CVEsHighest risk
0.00%0.41%0.83%1.24%0.2%0.7%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
🐘silverstripe/graphql🐘silverstripe/graphql

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

In SilverStripe/GraphQL prior to 2.0.5 and 3.1.2, the previous fix for SS-2018-007 does not completely mitigate the risk of CSRF in GraphQL mutations.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistsilverstripe/graphql≥ 2.0.0&&< 2.0.52.0.5composer require silverstripe/graphql:^2.0.5
🐘Packagistsilverstripe/graphql≥ 3.1.0&&< 3.1.23.1.2composer require silverstripe/graphql:^3.1.2

Affected Products

1 product · 1 configurations
Application
silverstripesilverstripe
≤ 4.3.3
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for silverstripe/graphql, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update silverstripe/graphql to 2.0.5 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-fx37-56v6-85q6 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

In SilverStripe/GraphQL prior to 2.0.5 and 3.1.2, the previous fix for SS-2018-007 does not completely mitigate the risk of CSRF in GraphQL mutations.
O3 Security · Impact-Aware SCA

Is GHSA-fx37-56v6-85q6 in your dependencies?

Find it across Packagist, including transitive dependencies.

Silverstripe CSRF Protection Bypass via GraphQL (High 8.8)